xmr-stak-rx

another coming network upgrade for monero, another fabulouspanda release? ;-)

Tagged:
«1

Comments

  • edited November 2019

    Hey pon,

    I've compiled xmr-stak-xr which is available on the downloads page now:
    http://downloads.fabulouspanda.co.uk/xmrstak/

    I tested it only on my system (which has all the dependencies so doesn't verify it'll work on a system without them) and without connecting to a pool so could you please try it out on the randomx test net as per this reddit post and let us know if it works for you?
    https://www.reddit.com/r/MoneroMining/comments/dfxpjy/minexmr_randomx_testnet_pool/

    It seems to work fine, I only checked CPU but it's showing around 1367.0 H/S on a 2012 Mac Pro using 6 threads with 100% good results. It does auto config with 6 threads despite this being a dual cpu Mac each with 6 cores, but running on 12 threads only brings the speed up to 1735.3 H/S.

  • tested it on a macmini 2012, ~700h/s; started without lib errors. next step will be a test on a amd equipped mac.

  • runs also on an imac 2019 with amd so it seems dependencies are or; amd hash seems very low with autoconfig, ~70h/s

  • Cool, thanks for checking! That does seem very low for AMD, have you seen any indication whether that's around what you should expect from the card and/or have you been able to improve it by tweaking the config?

  • i didn't try any tweaking, just took the autoconfig prefs to see if there are any errors.
    now i checked the amd.txt config file. asm is set to false, so no specifc assembler code (which should be available for the radeon 580x), when i set it to true i get
    [2019-11-25 23:18:40] : Compiling code and initializing GPUs. This will take a while...
    [2019-11-25 23:18:40] : WARNING: using non AMD device: Apple
    [2019-11-25 23:18:40] : Device 0 work size 16 / 32.
    [2019-11-25 23:18:40] : OpenCL device 0 - Load precompiled code from file /Users/home/.openclcache/5305de63c8ca2af1b1de694fe042b0716c85586d4f2823fefef89ac4670fe70f.openclbin
    [2019-11-25 23:18:40] : ERROR AMD: gcnAsm clCreateProgramWithBinary
    [2019-11-25 23:18:40] : WARNING: AMD device not found
    [2019-11-25 23:18:40] : WARNING: backend AMD (OpenCL) disable

  • I'm curious whether
    ERROR AMD: gcnAsm clCreateProgramWithBinary
    is caused by the pre-existing .openclbin – try running
    sudo rm -f /Users/home/.openclcache/5305de63c8ca2af1b1de694fe042b0716c85586d4f2823fefef89ac4670fe70f.openclbin (be careful with the rm -f command which deletes things and don't use it if you don't know what it does! In that case navigate to the containing folder using the 'Go' menu in the finder)
    then run xmr-stak-rx again?

  • tried it. no success:
    [2019-11-29 19:35:10] : Device 0 work size 16 / 32.
    [2019-11-29 19:35:10] : OpenCL device 0 - Precompiled code /Users/home/.openclcache/5305de63c8ca2af1b1de694fe042b0716c85586d4f2823fefef89ac4670fe70f.openclbin not found. Compiling ...
    [2019-11-29 19:35:11] : OpenCL device 0 - Precompiled code stored in file /Users/home/.openclcache/5305de63c8ca2af1b1de694fe042b0716c85586d4f2823fefef89ac4670fe70f.openclbin
    [2019-11-29 19:35:11] : ERROR AMD: gcnAsm clCreateProgramWithBinary
    [2019-11-29 19:35:11] : WARNING: AMD device not found
    [2019-11-29 19:35:11] : WARNING: backend AMD (OpenCL) disabled.

  • Not sure what's going on there… it could be down to the proprietary AMD drivers in macOS. Did this setting work prior to RandomX?
    They do however mention that GPU mining RandomX is not energy efficient in any case, so it may be worth using it only for CPU mining and putting the GPU to use for something else.

  • this is what i did.
    on catalina, i couldn't get it to run because of the new security crap. with gatekeeper disabled i can start xmr-stak-rx but loading the dylib says it's damaged. with gatekeeper enabler even xmr-stak-rx fails to run.

    for v1.02 they say cpu hashrate is further optimized: https://github.com/fireice-uk/xmr-stak/releases

  • You can add an exception for gatekeeper in Catalina, I added a note in the instructions

    "CATALINA EXTRA STEPS

    Due to increased security measures in 10.15 it’s necessary to add an exception for libssl.1.0.0.dylib (which is in xmr-stak/openssl/lib/ or xmr-stak/bin/openssl/lib/ for xmr-stak-rx), otherwise it’ll tell you libssl is damaged.

    The workaround is to use the command in Terminal sudo xattr -rd com.apple.quarantine /path/to/libssl.1.0.0.dylib (easiest to type in sudo xattr -rd com.apple.quarantine and then drag libssl.1.0.0.dylib in to the Terminal window so it autofills the path). This adds an exception for the library."

    I'll compile 1.0.2 soon

  • you're right, works with catalina. thats the problem when you don't read instructions to the end ;-)
    i had also to xattr the libxmrstak_opencl_backend.dylib but then it worked.

  • Ah, thanks for letting me know about the OpenCL backend! I'll add that to the instructions for 1.0.2

  • I've added 1.0.2 to the downloads page (but forgot to add that note about OpenCL backend -.- I'll get it next time!)
    http://downloads.fabulouspanda.com/xmrstak/
    Let me know whether you see any hash rate increase :)

  • thank you for the new version. speed seems up a bit but it's hard to say, i think ~5% perhaps. amd speed is still useless, so i have disabled it completely.
    as for the instructions i think you have to xattr all the .dylib (libssl, libcrypto, libxmrstak) and also xmr-stak itself on catalina.

  • I'll put together a more efficient command people can run as long as it's in the Applications folder for the next release, you can chain commands together with && so a simple copy paste should do it. I did try code signing them in 1.0.2 but I guess it didn't work out!

    Our of curiosity what are you doing with the GPU these days?

  • gpu is resting in my imac :-)
    regarding speed increase: the biggest brake is the memory warning on start. in fact, this makes a difference from ~2300h/s to ~3200h/s withourt warning with ident settings file on my imac. so i don't use the --noTest and make a restart when the memory warning comes up. didn't find an easier way to make it go away. tried memory cleanup tools, they have no effect

  • That's weird, what's the memory warning? And how much RAM is in the computer? I got the opportunity to test on a 2013 iMac with 16GB RAM running Catalina today and it's not giving me any memory warnings, but I've never tested on a machine with less than 16GB RAM and I have heard RandomX needs a lot of RAM. I'll compile 1.0.3 tomorrow which is supposed to be a bit faster again :)

    Also I noticed on Catalina you don't need to add that gatekeeper exception at the command line, you can just right-click all the dependencies it says can't be opened an choose open from that menu once for each and it makes an exception/the warning goes away.

  • i don't remember the exact warning msg. something about large memory page disabled or similar. i only got it after starting or restarting xmr-stak after using the mac for longer time and then got very low hashrates. after a restart the msg went away and hashrate back to normal. i think it's something about memory fragmentation, not low memory. one mac has 16gb ram, the other 24gb. next time i see it i'll make a copy of the msg ;-)

  • Hey Panda,
    Thanks for the xmr-stak-rx binary
    I had to run it with --noAMD on my 12 core 2009 mac pro with rx580 on catalina because the gpu part of the miner froze my screen, but I'm getting 2.6+Kh/s

  • as for the memory or whatever slowdown, the msg i get is:
    [2019-12-23 17:59:31] : MEMORY ALLOC FAILED: mmap failed, check attribute 'use_slow_memory' in 'config.txt'

    after this msg on startup of the miner the hashrate is very low. after a restart of the mac, msg is gone and speed back to normal. can't see any difference in cpu load.

  • Panda "Not sure what's going on there… it could be down to the proprietary AMD drivers in macOS. Did this setting work prior to RandomX?
    They do however mention that GPU mining RandomX is not energy efficient in any case, so it may be worth using it only for CPU mining and putting the GPU to use for something else."

    Hey Panda, while I did get the xmr-stak-rx to run on the gpu with your binary (too low of hash rate for the resources it consumes tho), your suggestion above is what I also have figured is the best idea- run the cpus on xmr and run the gpu on a coin that's more optimized for gpu mining.
    In fact I've been messing with grin, but I can't get the grin-miner to work with the gpu yet. Have you ever checked out grin?

  • graphic cards are pretty useless with the new algo. slow the computer to a snail and give very low hashrates. same for me. so --noAMD is the way to go ;-)

  • Hello again,

    Sorry for the delay – I had to update the version of openssl that's packaged with the miner. Could you please give it a shot? I've tested on another machine but I'd feel better knowing it works outside of my environments! For now I've just compiled a CPU only version without the web interface (which requires extra dependencies).
    http://downloads.fabulouspanda.com/xmrstak/

    I had look at grin-miner and it seems the AMD side of things requires the drivers which aren't available for macOS so unfortunately unless there's another miner around which doesn't that's not going to work right now. The majority of algorithms have this issue which makes GPU mining on Mac more than a little tricky.

  • ponpon
    edited January 2020

    no problem wirth delays ;-) some things need time ;-)
    is this still v1.02? atl east it says so when starting. i took the first in the list: http://downloads.fabulouspanda.com/xmrstak/xmrstakrx.dmg
    so if it's new, it still works for me
    any idea about the sporadic "MEMORY ALLOC FAILED: mmap failed" msg?

  • edited January 2020

    I think you have the older page cached, if you refresh the downloads page you'll get 1.0.4 or just get it here:
    http://downloads.fabulouspanda.com/xmrstak/xmr-stak-rx.cpu.1.0.4.zip
    Let me know if you get any hash rate increase too :)

    on that error they have instructions for fixing it on linux here:
    https://www.reddit.com/r/XmrStak/wiki/troubleshooting#wiki_7._memory_alloc_failed.3A_mmap_failed

    but for macOS you'd have to do something like
    ulimit -Sn 4096 && ulimit -Sl unlimited
    and
    launchctl limit maxfiles 10240 unlimited
    in terminal every time prior to running the miner (or put it in your bash profile so it sets those limits when the computer stars up). I'm not sure if that'll fix the issue but it's worth a shot.
    https://serverfault.com/questions/15564/where-are-the-default-ulimits-specified-on-os-x-10-5

  • ok, now i got v1.04. works. but only if put in the application folder. i had the older versions always on desktop. but with the new one it always search for the libs in the applications folder, if its not ther you get:
    Library not loaded: /Applications/xmr-stak/bin/openssl-1.1.1a/lib/libcrypto.1.1.dylib
    Referenced from: /Users/home/Desktop/xmr-stak/bin/./openssl-1.1.1a/lib/libssl.1.1.dylib
    Reason: image not found
    as for the speed, it seems to be a little bit faster.

  • Hi,
    trying to make use of my GPU. See that moneroocean.stream auto convert all alt coins to XMR. So thinking of mining Ryo with xmr-stak 2.10.1 on my AMD-card.
    Though I get following error:
    OpenCL device 0 - Precompiled code /Users/myuser/.openclcache/ed58579535c17dba6553ba6c2c0afd6e4e4e8e282cf7dead702d567159ac94be.openclbin not found. Compiling ...
    [2020-03-27 17:26:14] : Error CL_BUILD_PROGRAM_FAILURE when calling clBuildProgram.
    Build log:
    Error returned by cvms_element_build_from_source
    [2020-03-27 17:26:14] : WARNING: AMD device not found

    Any idea?

  • Downloaded xmr-stak version 2.10.1, unzipped it, moved xmr-stak folder to /Applications
    in terminal: cd to /Applications/xmr-stak
    sudo ./xmr-stak, entered password and got this:
    “libssl.1.0.0.dylib” is damaged and can’t be opened. You should move it to the Trash."

  • edited November 2020

    @sanyi said:
    Downloaded xmr-stak version 2.10.1, unzipped it, moved xmr-stak folder to /Applications
    in terminal: cd to /Applications/xmr-stak
    sudo ./xmr-stak, entered password and got this:
    “libssl.1.0.0.dylib” is damaged and can’t be opened. You should move it to the Trash."

    That's due to increased security procedures on newer versions of macOS, you can get around it by right-clicking libssl.1.0.0.dylib and choosing open, then when a warning comes up opening it anyway. Next time you run xmr-stak you won't have the same issue. You could also disable gatekeeper to make it work without doing it, but I wouldn't recommend it. Those security checks are there for a reason.

  • I assume you mean the libssl.1.0.0.dylib file in xmr-stak/openssl/lib. Well, I did as you suggested (right click -> open), but the pop up window just says the same thing: "libssl.1.0.0.dylib” is damaged and can’t be opened. You should move it to the Trash.", and does not offer any choices other than "Cancel" or "Move to Trash". Then, I also tried to build my own, following your instructions but it also ran into compile errors:

    1. brew install cmake openssl hwloc libmicrohttpd
      Updating Homebrew...
    2. git clone https://github.com/fireice-uk/xmr-stak.git
      Cloning into 'xmr-stak'...
      remote: Enumerating objects: 9247, done.
      remote: Total 9247 (delta 0), reused 0 (delta 0), pack-reused 9247
      Receiving objects: 100% (9247/9247), 5.28 MiB | 41.00 KiB/s, done.
      Resolving deltas: 100% (6599/6599), done.

    3. cd xmr-stak

    4. cmake -DOPENSSL_ROOT_DIR=/usr/local/opt/openssl -DCUDA_ENABLE=OFF
      -- The C compiler identification is AppleClang 11.0.0.11000033
      -- The CXX compiler identification is AppleClang 11.0.0.11000033
      -- Detecting C compiler ABI info
      -- Detecting C compiler ABI info - done
      -- Check for working C compiler: /Library/Developer/CommandLineTools/usr/bin/cc - skipped
      -- Detecting C compile features
      -- Detecting C compile features - done
      -- Detecting CXX compiler ABI info
      -- Detecting CXX compiler ABI info - done
      -- Check for working CXX compiler: /Library/Developer/CommandLineTools/usr/bin/c++ - skipped
      -- Detecting CXX compile features
      -- Detecting CXX compile features - done
      -- Looking for CL_VERSION_2_2
      -- Looking for CL_VERSION_2_2 - not found
      -- Looking for CL_VERSION_2_1
      -- Looking for CL_VERSION_2_1 - not found
      -- Looking for CL_VERSION_2_0
      -- Looking for CL_VERSION_2_0 - not found
      -- Looking for CL_VERSION_1_2
      -- Looking for CL_VERSION_1_2 - found
      -- Found OpenCL: /Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk/System/Library/Frameworks/OpenCL.framework (found version "1.2")
      -- Looking for pthread.h
      -- Looking for pthread.h - found
      -- Performing Test CMAKE_HAVE_LIBC_PTHREAD
      -- Performing Test CMAKE_HAVE_LIBC_PTHREAD - Success
      -- Found Threads: TRUE
      -- Found OpenSSL: /usr/local/opt/openssl/lib/libcrypto.dylib (found version "1.1.1h")
      -- The ASM compiler identification is Clang
      -- Found assembler: /Library/Developer/CommandLineTools/usr/bin/cc
      -- Configuring done
      -- Generating done
      -- Build files have been written to: /Users/anyuci/xmr-stak

    5. make install
      and this last step resulted in the following:
      Scanning dependencies of target xmr-stak-asm
      [ 2%] Building ASM object CMakeFiles/xmr-stak-asm.dir/xmrstak/backend/cpu/crypto/asm/cryptonight_v8_main_loop.S.o
      [ 5%] Building ASM object CMakeFiles/xmr-stak-asm.dir/xmrstak/backend/cpu/crypto/asm/cnR/CryptonightR_template.S.o
      [ 7%] Linking C static library bin/libxmr-stak-asm.a
      [ 7%] Built target xmr-stak-asm
      Scanning dependencies of target xmr-stak-c
      [ 10%] Building C object CMakeFiles/xmr-stak-c.dir/xmrstak/backend/cpu/crypto/c_blake256.c.o
      [ 12%] Building C object CMakeFiles/xmr-stak-c.dir/xmrstak/backend/cpu/crypto/c_groestl.c.o
      [ 15%] Building C object CMakeFiles/xmr-stak-c.dir/xmrstak/backend/cpu/crypto/c_jh.c.o
      [ 17%] Building C object CMakeFiles/xmr-stak-c.dir/xmrstak/backend/cpu/crypto/c_keccak.c.o
      [ 20%] Building C object CMakeFiles/xmr-stak-c.dir/xmrstak/backend/cpu/crypto/c_skein.c.o
      [ 23%] Linking C static library bin/libxmr-stak-c.a
      [ 23%] Built target xmr-stak-c
      Scanning dependencies of target xmr-stak-backend
      [ 25%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/backend/backendConnector.cpp.o
      [ 28%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/backend/cpu/cpuType.cpp.o
      [ 30%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/backend/cpu/crypto/CryptonightR_gen.cpp.o
      [ 33%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/backend/cpu/crypto/cn_gpu_avx.cpp.o
      [ 35%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/backend/cpu/crypto/cn_gpu_ssse3.cpp.o
      [ 38%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/backend/cpu/crypto/cryptonight_common.cpp.o
      [ 41%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/backend/cpu/hwlocMemory.cpp.o
      [ 43%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/backend/cpu/jconf.cpp.o
      [ 46%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/backend/cpu/minethd.cpp.o
      [ 48%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/backend/globalStates.cpp.o
      [ 51%] Building CXX object CMakeFiles/xmr-stak-backend.dir/xmrstak/http/httpd.cpp.o
      /Users/anyuci/xmr-stak/xmrstak/http/httpd.cpp:160:6: error: no matching function for call to 'MHD_start_daemon'
      d = MHD_start_daemon(MHD_USE_THREAD_PER_CONNECTION,
      ^~~~
      /usr/local/include/microhttpd.h:2425:1: note: candidate function not viable: no known conversion from 'int
      (*)(void *, MHD_Connection *, const char *, const char *, const char *, const char *, size_t *, void **)'
      (aka 'int (*)(void *, MHD_Connection *, const char *, const char *, const char *, const char *, unsigned
      long *, void **)') to 'MHD_AccessHandlerCallback' (aka 'MHD_Result (*)(void *, MHD_Connection *, const
      char *, const char *, const char *, const char *, unsigned long *, void **)') for 5th argument
      MHD_start_daemon (unsigned int flags,
      ^
      1 error generated.
      make[2]: *** [CMakeFiles/xmr-stak-backend.dir/xmrstak/http/httpd.cpp.o] Error 1
      make[1]: *** [CMakeFiles/xmr-stak-backend.dir/all] Error 2
      make: *** [all] Error 2

    Which is certainly looks like a coding issue and of course one could dig into the source but that's not the point of this exercise. A stable release should build and I'm sure it does for other people, so my question is: what am I doing differently? This is on Catalina 10.15.5. Any thoughts?
    Maybe the step where it is looking for CL version 2.2, then it downshifts to 2.1, then to 2.0, and then finally to 1.2? Could that be the problem?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file