Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Buy bitcoins anywhere in the world at

Buy Monero at local Monero

Trade BTC for Monero at AgoraDesk

Use Anonymous Ads
Use Anonymous Ads

Antminer U3 settings?

I am trying to mine with a U3 Antminer with macminer without succes. The antminer does work with the bitmain cgminer wich is only available for windows.

Is there a way to run the U3 antminer with macminer?




  • I was able to get my U3 running, but it's only mining at 4 GH/s, not the advertised 63 GH/s.

    I was able to install the Mac version of the necessary drivers from Silicon Labs. Once I did, I was able to get it mining via the standard settings in MacMiner's FPGA/ASIC Minder.

    However, I can't figure out how to set it so that it will clock properly. Does anyone know how to change the settings in MacMiner so that my U3 will pull the correct 63 GH/s?

    I've been assuming that it is done within the config file, but I only have the parameters to use when running the cgminer.exe file in Windows. Even trying the parameters when running the cfgminer in the Terminal from MacMiner doesn't seem to work.
  • edited January 2015
    To add details, I've tried adding the following flags both to MacMiner and to cgminer in the Terminal:

    This from the U3 instructions:
    --bmsc-options 115200:0.54 --bmsc-voltage 0800 --bmsc-freq 0982 --startdiff 6

    And this from online forums I've combed:

    --au3-freq 250 --au3-volt 820

    (I'm not quite sure why the frequency is so different between those two...)

    Both cause an unrecognized command error in MacMiner. CGMiner I haven't even gotten to work with my U2 or U3.
  • edited January 2015
    And here is the API Output for the U3, in case that is helpful:

       [PGA] => 1
       [Name] => AMU
       [ID] => 0
       [Enabled] => Y
       [Status] => Alive
       [Device Elapsed] => 80683
       [MHS av] => 4075.086
       [MHS 20s] => 3448.976
       [MHS rolling] => 3448.976
       [Accepted] => 10777
       [Rejected] => 2145
       [Hardware Errors] => 1
       [Utility] => 8.014
       [Stale] => 0
       [Last Share Pool] => 0
       [Last Share Time] => 1420215526
       [Total MH] => 328792063.4707
       [Diff1 Work] => 102904
       [Work Utility] => 76.524
       [Difficulty Accepted] => 86411.99999920
       [Difficulty Rejected] => 17187.99999987
       [Difficulty Stale] => 0
       [Last Share Difficulty] => 8
       [Last Valid Work] => 1420215531
       [Device Hardware%] => 0.0010
       [Device Rejected%] => 16.7029
  • FYI, I have since given up on MacMiner and grabbed a cheap laptop to run cgminer in windows. Works perfectly fine here. Although I had a moment where it dropped down to 20 GH/s. I unplugged it for a bit, relocated it closer to a fan, and restarted cgminer without the added freq and volt settings. It's running fine now, though about 5–8 GH/s slower. But if it stays running at that rate, that's all that counts
  • Turns out my freq was just a bit high. I dialed it back to 800 from 820 and my U3 has be running splendidly along with my other devices with cgminer on Windows. Sorry that MacMiner didn't work out, but so it goes!
  • Hi, sorry for the late response...

    ASIC window uses bfgminer and luke-jr hasn't got a device to test with, says bitmain have not been supportive of bfgminer - so not sure you can set clock but for a U2 you'd do it like this:
    --set-device antminer:clock=x0981

     if you want to give MacMiner another shot try that first or the cgminer window with the same flags you use on windows but you'll probably have to uninstall the silicon labs drivers first. cgminer requires no drivers installed, bfgminer requires them and they can't work concurrently with the same brand of asic
  • edited January 2015
    Hello, I just got the Antminer u3 today, I got it all set up and running, but I can't seem to get more than 4gh/s. I'm am running it through my Raspberry Pi b+. I tried running cgminer and bfgminer, both gave me the same results. Is there any way I can adjust this? Thank you.

    PS. I don't know how to adjust the clocking through the pi. Still fairly new to the pi.
  • Hi everyone, I've compiled the latest bfgminer source which has changes since 5.1 which will be released in 5.2 - This includes Antminer U3 support! Please let me know how you get on. 

    The bfgminer version has only been tested on Linux, but as Mac OS has many similarities it should work here too. Just plug in and start up the FPGA/ASIC window - let me know how it goes!
  • Hi FabulousPanda! Thanks for your efforts!

    I'm running 1.5.25b with my Antminer U3 (silver dome version) at 2Gh. When I first set it up, started at around 300Gh, then gradually dropped to 2Gh. Havent' been able to get it higher yet.

    "--set-device antminer:clock=x0881" does not appear to have an effect.

    Will look around for some more flags to try, still very new to all of this.


  • edited April 2015
    Forgot to mention that I was using "-S antminer:all" as well (tested with and without the set-device flag), as per

    So, I've just tried it again and it is now running at 30ghs... I've been going through a similar process for each new setting change attempt, but for some reason, this time appears to be working (must be now facing west? just needed to really warm up?).

    Thanks again!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file