Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Buy bitcoins anywhere in the world at

Buy Monero at local Monero

Trade BTC for Monero at AgoraDesk

Use Anonymous Ads
Use Anonymous Ads

GAW Miner Fury a.k.a. Zeus Blizzard

edited June 2014 in Support
I've been running my first purchased ASIC, a Gridseed 5-chip "Orb" (Tuna Can) miner with MacMiner since I got, it about a month ago.

I ordered a week 5 GAW Miner "Fury" and zenController, but my order was SNAFUed and I now have a $185 paperweight because the zenController hasn't been shipped.

I have a MacMini3,1 running the latest 10.9.3 Mavericks and have updated to MacMiner v1.5.21b2

I also have a laptop reformatted to a Xubuntu 14.04 "Trusty" install, Intel Pentium M 32bit single core CPU and Intel 940x IG GPU.

I have tried every article/ tip/ clipping/ forum suggestion I could find. NOTHING works with this FURY.

(I even tried downloading various versions of Android OS variants to try to use my Allwinner A20 - 7" android tablet to work in place of their zenController.)

I come to find out, a bit late, that even the latest version of their own ZenOS, doesn't run FURY + Gridseed simultaneously.

I have no issue running the Gridseed on the Xubuntu laptop under terminal until things settle a bit more for the Scrypt ASIC community, but, if at all possible, could you please compile a working FURY controller for MacMiner, for OS X 10.9.x Mavericks as this paperweight is seriously eating a hole in my wallet, sitting here on the shelf doing nothing.

[edit] added Tags


  • The official Mac OS compilation seems to be damaged, or it's a problem with that awful mega download manager they're using… the code won't compile for me so I've put an issue in with the problem at the github - if I get time I'll see if it's an easy fix!
  •  - if I get time I'll see if it's an easy fix!
  • bfgminer has just now been updated to support zeusminer and I assume these devices - look for an update within 24hrs - i'm out now though!
  • Please update MacMiner to the latest beta version - the included bfgminer has been updated :)
  • edited July 2014
    I had a play, I found you have to manually put the -s zus:/dev/cu.SLAB_USBtoUART code in to find your miner

    Not sure about multiple miners. but ls -l /dev/cu.* should show you
    or possibly -S zus:all which works on BFgminer 
  • my current setup running 1 Gridseed 5-chip and 1 zeus blizzard 6 chip:

    -T -d zus -S zus:/dev/cu.SLAB_USBtoUART -d GSD -S gridseed:/dev/cu.usbmodem26241 --force-dev-init --set-device gridseed:clock=868

    Clock speed will obviously be independent for each device and different for everyone... this speed gave me an average hashrate of 458KHs on that gridseed with less than 1% HW errors.

    I have an RPi and GAW Fury on order, when they get here I'll use MacMiner to find the best settings for each device before adding to my mini-farm.

    MacMiner = Indispensable Tool!!!!! Thanks so much for doing this... Donation on it's way to you!

  • Thanks Doc, your generosity is very much appreciated! 

    What's with the 

    -d zus
    -d GSD
    flags? I wonder if that has something to do with the failure to restart the zeus' - probably not, more likely just takes a a second to free up after miner restart… I'll introduce a brief delay!
  • edited July 2014
    If I don't set the -d *** flag, it also finds my MacMini3,1 integrated Nvidia GeForce 9400 which is the single WORST graphics card to mine on (even worse than CPU mining on a stock Mini), and is the reason for so many windows users saying "Don't Mine on a Mac!"

    By setting the -d flags, all other devices are disabled. This not only speeds up mining, but also leaves my Mac free to run as my desktop machine.


    (EDIT: in re-reading the BFG documentation, the -d flag is 'pattern matching'... I wonder if I could simply -d -OCL ?)

    (EDIT: Nope:

     [2014-07-05 08:08:06] cgpu_match: Invalid syntax: -OCL

    Oh well, back to -d zus -d gsd ...)

  • That's really peculiar, must be an artefact of Scrypt mining as it doesn't happen on the sha256 end - unfortunately I don't have a scrypt miner to test the theory with. 

    -G used to be 'disable GPU' but I'm pretty sure that was removed - you could try -S noauto  to save multiple entries? 
  • Oh, and i read that some of these miners have buggy firmware which can sometimes cause it to be picked up (possibly the issue you had?) - it recommended this:

    --set zus:ignore_golden_nonce=1
  • after dealing with these issues for 5+ hours, I was finally able to figure out the command needed to type into my terminal (running bfgminer) to resolve these issues.NOTE I am not using Mac Miner at all, but it should work as well. It ended up being a collection of a lot of the difference command advice I found on this forum. But, as long as you are running the most recent bfgminer firmware and have the proper sil labs osx drivers for the gaw fury installed, this should work (type directly into a blank terminal)

    bfgminer --scrypt -o (your pool URL) -u (your worker/user name) -p ( your password) -S zus:/dev/cu.SLAB_USBtoUART
     --set zus:ignore_golden_nonce=1

    My Zues Gaw Fury Miner is up and running plugged into an OSX 10.10 because of this command. Thank you all collectively for the help god knows how long it would have taken  to get it up and running without this thread.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file