Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Buy bitcoins anywhere in the world at

Buy Monero at local Monero

Trade BTC for Monero at AgoraDesk

Use Anonymous Ads
Use Anonymous Ads

MobileMiner users - please update

Hey everyone,

Due to an update in the MobileMiner API it is necessary for users to upgrade to the latest version of MacMiner, 1.5.20b1, for MobileMiner to continue to function.

This update also upgrade bfgminer to the latest from github so I'd very much like users to give that a shot with gridseed devices!


  • edited May 2014
    Thank you!
    I've noticed that in this version the Accepted/Rejected counts are not displayed anymore, at least in the CG Miner window.

    I'm also seeing this error in system.log shortly after I start MacMiner:

    05/05/14 16:29:45,892 MacMiner[30279]: (
        0   CoreFoundation                      0x00007fff930ccb06 __exceptionPreprocess + 198
        1   libobjc.A.dylib                     0x00007fff8ed913f0 objc_exception_throw + 43
        2   CoreFoundation                      0x00007fff930cc8dc +[NSException raise:format:] + 204
        3   Foundation                          0x00007fff96ef5fca -[NSPlaceholderString initWithFormat:locale:arguments:] + 100
        4   Foundation                          0x00007fff96ef711c +[NSString stringWithFormat:] + 170
        5   MacMiner                            0x000000010fdd310a MacMiner + 16650
        6   MacMiner                            0x000000010fdeca25 MacMiner + 121381
        7   Foundation                          0x00007fff96f12443 __NSFireTimer + 96
        8   CoreFoundation                      0x00007fff93089804 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20
        9   CoreFoundation                      0x00007fff9308931d __CFRunLoopDoTimer + 557
        10  CoreFoundation                      0x00007fff9306ead9 __CFRunLoopRun + 1529
        11  CoreFoundation                      0x00007fff9306e0e2 CFRunLoopRunSpecific + 290
        12  HIToolbox                           0x00007fff8ceb9eb4 RunCurrentEventLoopInMode + 209
        13  HIToolbox                           0x00007fff8ceb9c52 ReceiveNextEventCommon + 356
        14  HIToolbox                           0x00007fff8ceb9ae3 BlockUntilNextEventMatchingListInMode + 62
        15  AppKit                              0x00007fff9379a533 _DPSNextEvent + 685
        16  AppKit                              0x00007fff93799df2 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
        17  AppKit                              0x00007fff937911a3 -[NSApplication run] + 517
        18  AppKit                              0x00007fff93735bd6 NSApplicationMain + 869
        19  MacMiner                            0x000000010fdd0c5c MacMiner + 7260
        20  ???                                 0x0000000000000002 0x0 + 2

  • Ah, most of the miners have been changing from 5 second average to 20 - I suspect this to be the issue - please redownload the latest version and let me know whether that fixes it for you!
  • The last 1.5.20b1 version doesn't output that error in the system log but it doesn't display the hashrate and the accepted/rejected share counts, either. I'm using the CG Miner window. With this version hashrate is always 0 Mh and I see the "Accepted:" and "Rejected:" words but there isn't any number next to them. The cgminer output shows that shares are being accepted though.
  • Can you please post the line that looks most like this for me?

    20s:68.68 avg:68.65 u:67.93 Gh/s | A:22096 R:82+0(.41%) HW:1045/.07%   

  • The latest version of MacMiner, v1.5.20b1, doesn't show the hash rate in the FPGA/ASIC Miner view.  Prior to this release, it did!
  • MobileMiner still doesn't work with this latest release.  Yes, I have my settings in MacMiner for MobileMiner.
  • Like this one?

    (5s):237.0M (1m):323.3M (5m):328.8M (15m):329.3M (avg):329.8Mh/s

    This is a screenshot of the window, HTH.
  • I guess I should move away from taking the figures from the log and just use the figures from the API! Thanks for the report.

    I haven't noticed the FPGA/ASIC window not showing the hash rate more than temporarily, has the problem continued and what hardware are you using it with? 

    Re: MobileMiner can you please check the Console app in Utilities folder and see whether MacMiner is giving you any messages about why it's failing?
  • This is a screenshot of the window, HTH.
    Same issue with 1.5.20b2.
  • The  window figures haven't been fixed yet and will require a slightly bigger change - expect that in the .21b's 

    Right now MobileMiner should work for figures but fail for commands, causing some 404 errors, this will be addressed in the next update :)
  • 1.5.20 has been updated for the last time, this updates bfgminer very slightly, and should fix cgminer hash rate display but not share counts. Beta versions will resume shortly.
  • Yes, thank you, cgminer hashrate display is fixed now!
  • I have installed MacMiner v1.5.20gm, and I can report:

    1)  On the FPGA/ASIC Divice Miner view, the hashrate is still showing 0 Mh, despite the miners running as shown in the API view

    2)  I have 3 Red Bitfuries connected to this Mac, and 2 Antminer S1's connected via network, all 5 are correctly reported in the API View.  But only the 3 Bitfuries and 1 Antminer S1 is showing up in MobileMiner, albeit the Hashrate is correctly reported in MobileMiner
  • I was on .20b3 earlier and looking at my pool stats I was getting about 50% what I did on previous versions, and my Antminer S2s weren't even warm. And the FPGA/ASIC showed 0MH/s as well as not updating the log window to show anything useful.

    It would also crash on that computer every time I restarted it, but that was "normal" lately for previous versions too. I just delete the bfgurls.conf in the App Support folder. I decided to move to a different computer & tried .20gm too (oops, 2 variables) and now it crashes a bit differently. *sigh* I'm going to try to delete my settings & start over to see what happens. :-/
  • *sigh* crashes after 30 seconds or so. I guess I'll go beck to .18e for now.
  • Once I got bast the crash on startup, .18e appears to be working.
  • Thanks for the reports, OldTimer I should have those problem fixed in 1.5.21 :)

    Max, Can you please post a crash report here for the two different crashes? I'm hoping this is at least a sign that I'm homing in on the problem! 
  • Startup Crash (18e & up):

    Post Startup Crash (20gm):
    (just under a minute after startup, I haven't managed to get a screenshot right before it happens though. :) )

  • Thanks Max, that's handy! I'm glad to see I'm past the first crash now I just need to figure out the second - had you started mining before it crashed and if so does it crash if you don't? Also, had you set up MobileMiner? The MobileMiner integration code runs on a 30 second loop so that's my prime suspect right now.
  • 1.5.20gm has been slyly replaced with an updated version containing 2 important bug fixes

    • This should finally be the end of the crashing bug - please report back!

    • I made a stupid mistake which prevented correct LTC pool setup which is fixed here
  • Well, actually you aren't past the first crash as of the last version I tried. I got past it by deleting the bfgurls.conf before launching. I'll give the new .20gm a try. :)
  • Well, actually you aren't past the first crash as of the last version I tried. I got past it by deleting the bfgurls.conf before launching. I'll give the new .20gm a try. :)
    Please do - I'm pretty sure it was fixed in another sneaky update about 20mins ago!
  • Hahah. Yeah, the startup crash is gone. But the 30 seconds in crash is still there. I'll try it again with MobileMiner turned off (if I can do it fast enough :) ).

    Post Startup Crash (20gm):
    (maybe between 30 sec & a minute after startup, I think it had started hashing, but it's hard to tell with the status display the way it is.)

  • I hit Stop after starting up & let it sit there over a minute & it was fine. So, I hit Start. ~25 seconds later, boom! :)

    I deleted my MobileMiner info and quit & restarted the app. Still the same result. Just under 25 seconds in.
  • Awwww it is at least a slightly different crash - will take another gander!
  • which miner window are you using btw?
  • One last thing - I don't suppose you have Xcode installed?
  • Antminer S2 ... 2 of them. I don't think I have Xcode loaded on that machine, but I guess I could. I should warn you, I haven't used Xcode for anything more than to look at .plists though. :-)

  • ooh nice. It would be awesome if you had Xcode - I could walk you through a quick test which could show us the exact line of code causing the problem :)
  • It's downloading now ... I'll install it tomorrow. :) (I had to hunt down the old version, since that MacBook is on 10.7)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file