Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Buy bitcoins anywhere in the world at

Buy Monero at local Monero

Trade BTC for Monero at AgoraDesk

Use Anonymous Ads
Use Anonymous Ads

GPU / CPU Mining now mining

edited February 2018 in General

Hi everyone! I am new here and in the mining industry and just recognized that my CPU Miner and GPU Miner show "Starting... " but nothing happens! I have macOS HighSierra version 10.13.1 and AMD Radeon HD 6770 M Grafik card.

I installed this version of MacMiner

I try to mine StrongHands / SHA256 at CPU and FuturoCoin / X11 at GPU. I left standard settings.

I click on start but no mining, I also set stratum+tcp:// but nothing happens, so Simply turn MacMiner off and on, than switched SHA256 to GPU and X11 to CPU - voila! It worked out.

BUT CPU Mining uses up to 360% CPU! What is possible to do, to reduce this value significantly?

Now I also could try to GPU Mine X11 - but there occurs there errors PLUS Energy and CPU increases enormously! Peary dangerously... ;-)

Here the error report:

Starting…[22:05:30] Set default algorithm to darkcoin-mod
[22:05:30] Global quota greatest common denominator set to 1
[22:05:30] Started sgminer
[22:05:30] * using Jansson 2.7
[22:05:30] Loaded configuration file /Users/apple/Library/Application Support/MacMiner/x11urls.conf
[22:05:30] CL Platform vendor: Apple
[22:05:30] CL Platform name: Apple
[22:05:30] CL Platform version: OpenCL 1.2 (Sep 6 2017 16:05:06)
[22:05:30] Platform devices: 1
[22:05:30] 0 ATI Radeon HD 6770M
[22:05:30] Default Devices = all
[22:05:30] set_devices(all)
[22:05:30] Loading settings from default_profile for pool 0
[22:05:30] Pool 0 Algorithm set to "darkcoin-mod"
[22:05:30] Pool 0 devices set to "all"
[22:05:30] Pool 0 lookup gap set to "(null)"
[22:05:30] Pool 0 Intensity set to "4"
[22:05:30] Pool 0 Thread Concurrency set to "(null)"
[22:05:30] Pool 0 Shaders set to "(null)"
[22:05:30] Pool 0 Worksize set to "(null)"
[22:05:30] WARNING: GPU_MAX_ALLOC_PERCENT is not specified!
[22:05:30] WARNING: GPU_USE_SYNC_OBJECTS is not specified!
[22:05:30] Probing for an alive pool
[22:05:30] Testing
[22:05:30] Succeeded delayed connect
[22:05:30] Failed to get sessionid in initiate_stratum
[22:05:30] difficulty changed to 5072.670
[22:05:30] Cannot subscribe to mining.extranonce on
[22:05:30] Stratum authorisation success for
[22:05:30] alive
[22:05:30] Startup GPU initialization... Using settings from pool
[22:05:30] Startup Pool No = 0
[22:05:30] compare_pool_settings()
[22:05:30] difficulty set to 5072.669524
[22:05:30] set_devices(all)
[22:05:30] Switching to intensity: pool = 4, default = 4
[22:05:30] intensity -> 4
[22:05:30] [THR0] gen_stratum_work() - algorithm = darkcoin-mod
[22:05:30] Set GPU 0 to darkcoin-mod
[22:05:30] [THR0] Generated stratum merkle 8378799e590b5895c5b6289753fed16ede19a254007160d859c3446ea733129e
[22:05:30] Allocate new threads...
[22:05:30] [THR0] Generated stratum header 200000008ba474d51bd738a159e68d1447666c2a7cc12bb70afd199c00001021000000008378799e590b5895c5b6289753fed16ede19a254007160d859c3446ea733129e5a7a188b1a2a344a00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
[22:05:30] Assign threads for device 0
[22:05:30] [THR0] Work job_id 172886835536393507837472340375876775423 nonce2 0 ntime 5a7a188b
[22:05:30] Thread 0 set pool = 0 (
[22:05:30] [THR0] Generated target 0000000000000000000000000000000000000080112338dc52eb0c0000000000
[22:05:30] Init GPU thread 0 GPU 0 virtual GPU 0
[22:05:30] CL Platform vendor: Apple
[22:05:30] CL Platform name: Apple
[22:05:30] New block: 00000000000010210afd199c7cc12bb747666c2a59e68d141bd738a18ba474d5... diff 398K
[22:05:30] CL Platform version: OpenCL 1.2 (Sep 6 2017 16:05:06)
[22:05:30] Platform devices: 1
[22:05:30] 0 ATI Radeon HD 6770M
[22:05:30] List of devices:
[22:05:30] 0 ATI Radeon HD 6770M
[22:05:30] Selected 0: ATI Radeon HD 6770M
[22:05:30] [THR0] gen_stratum_work() - algorithm = darkcoin-mod
[22:05:30] [THR0] Generated stratum merkle c0fabd693876db27e4802a5da8f62454e4a664288363aaf1aaee20219b744829
[22:05:30] [THR0] Generated stratum header 200000008ba474d51bd738a159e68d1447666c2a7cc12bb70afd199c0000102100000000c0fabd693876db27e4802a5da8f62454e4a664288363aaf1aaee20219b7448295a7a188b1a2a344a00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
[22:05:30] [THR0] Work job_id 21959952059608245047687826238365221417 nonce2 0 ntime 5a7a188b
[22:05:30] [THR0] Generated target 0000000000000000000000000000000000000080112338dc52eb0c0000000000
[22:05:30] Preferred vector width reported 4
[22:05:30] Max work group size reported 256
[22:05:30] Maximum work size for this GPU (0) is 256.
[22:05:30] Your GPU (#0) has 6 compute units, and all AMD cards in the 7 series or newer (GCN cards) have 64 shaders per compute unit - this means it has 384 shaders.
[22:05:30] Max mem alloc size is 134217728
[22:05:30] Using source file
[22:05:30] GPU 0: selecting lookup gap of 2
[22:05:30] GPU 0: selecting thread concurrency of 960
[22:05:30] Setting worksize to 256
[22:05:30] Using binary file darkcoin-modATI Radeon HD 6770Mgw256l8ku0.bin
[22:05:30] No binary found, generating from source
[22:05:30] Building binary darkcoin-modATI Radeon HD 6770Mgw256l8ku0.bin
[22:05:30] Trying to open /Applications/
[22:05:30] Using /Applications/
[22:05:30] CompilerOptions: -I "/Applications/" -I "/Applications/" -I "." -D WORKSIZE=256 -I "/Applications/" -D SPH_COMPACT_BLAKE_64=0 -D SPH_LUFFA_PARALLEL=0 -D SPH_KECCAK_UNROLL=0


  • I tested mining stronghands with

    on GPU and it started fine, what happens when you try?

    With X11 GPU mining it works fine, don't be alarmed by the output, only it won't show the accepted shares in the GPU miner window, only in the API output window for the GPU. However when I tested it around 550kh/s it took a few minutes between accepted shares.

    For CPU mining you can enter how many threads you want to use in the miner options panel, or use the manual flag
    -t 1

    where 1 is the number of threads, so if it runs 4 threads without that setting running -t 2 should half the cpu usage.

  • edited February 2018

    Hi there! stronghands (SHA 256) mining works out fine now as well at GPU!

    According additional futurocoin (X11) pool mining at GPU: Is this possible? Can I mine both coins parallel to each other at GPU ?

    Thank you for your support!

  • While GPU mining two coins on the same card simultaneously is theoretically possible it's not a good idea and it wouldn't be advisable. Best case scenario they'd both run at half speed but I doubt it would work well.

  • edited February 2018

    Sorry but CPU Miner again Issues: [2018-02-12 12:38:02] Using JSON-RPC 2.0[0m
    [2018-02-12 12:38:02] CPU Supports AES-NI: YES[0m
    [2018-02-12 12:38:02] Starting Stratum on stratum+tcp://[0m
    [2018-02-12 12:38:02] 4 miner threads started, using 'cryptonight' algorithm.[0m
    [2018-02-12 12:38:02][31m JSON invalid result[0m
    [2018-02-12 12:38:02][33m rpc2_login_decode: fail[0m
    [2018-02-12 12:43:02][31m Stratum connection timeout[0m
    [2018-02-12 12:43:02][31m Stratum connection interrupted[0m
    [2018-02-12 12:43:02][31m JSON invalid result[0m
    [2018-02-12 12:43:02][33m rpc2_login_decode: fail[0m
    [2018-02-12 12:48:02][31m Stratum connection timeout[0m
    [2018-02-12 12:48:02][31m Stratum connection interrupted[0m
    [2018-02-12 12:48:02][31m JSON invalid result[0m
    [2018-02-12 12:48:02][33m rpc2_login_decode: fail[0m

  • I just tried this pool and I had the same issue, I'm not sure what's up with that. It works with so the issue seems to be pool related though, you could ask them about it or try a different pool.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file