Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Buy bitcoins anywhere in the world at

Buy Monero at local Monero

Trade BTC for Monero at AgoraDesk

Use Anonymous Ads
Use Anonymous Ads

Very low Hashrate mining Garlicoin on sgminer (GTX970)

edited February 2018 in Support

Hi all.

I have a MacBook Pro 15" late 2016 and want to mine using an eGPU (GeForce GTX970) attached to it via an Akitio Thunder 2.
I have followed the tutorial ( and everything seemed to work. However I am getting a very low Hashrate of 1.75 KH/s. This surprises me since according to my GPU should produce about 250 KH/s.
I then downloaded the compiled sgminer-gm from fabulouspanda and run following command:
"./sgminer --algorithm scrypt-n --nfactor 11 -o stratum+tcp:// -u jarikut.GeForceGTX970 -p x -I 9 -d 2"
The Hashrate increased to 11.6 KH/s which is better but still pretty far away from anything with three digits.

Also the algorithm scrypt-n seems to not exist since it switches to ckolivas instead?

Here is the output of the Terminal after I quit mining:

[20:50:09] Algorithm scrypt-n not found, using ckolivas.
Summary of runtime statistics:

[20:57:00] Started at [2018-02-04 20:50:11]
[20:57:00] Pool: stratum+tcp://
[20:57:00] Runtime: 0 hrs : 6 mins : 49 secs
[20:57:00] Average hashrate: 11.6 Kilohash/s
[20:57:00] Solved blocks: 0
[20:57:00] Best share difficulty: 126
[20:57:00] Share submissions: 22
[20:57:00] Accepted shares: 22
[20:57:00] Rejected shares: 0
[20:57:00] Accepted difficulty shares: 80
[20:57:00] Rejected difficulty shares: 0
[20:57:00] Reject ratio: 0.0%
[20:57:00] Hardware errors: 0
[20:57:00] Utility (accepted shares / min): 3.23/min
[20:57:00] Work Utility (diff1 shares solved / min): 11.73/min

[20:57:00] Stale submissions discarded due to new blocks: 0
[20:57:00] Unable to get work from server occasions: 0
[20:57:00] Work items generated locally: 315
[20:57:00] Submitting work remotely delay occasions: 0
[20:57:00] New blocks detected on network: 7

[20:57:00] Summary of per device statistics:

[20:57:00] GPU0 | (5s):0.000 (avg):0.000h/s | A:0 R:0 HW:0 WU:0.000/m
[20:57:00] GPU1 | (5s):0.000 (avg):0.000h/s | A:0 R:0 HW:0 WU:0.000/m

[20:57:00] GPU2 | (5s):11.66K (avg):11.63Kh/s | A:80 R:0 HW:0 WU:11.731/m

I was wondering what I was doing wrong.
If you have an idea, please let me know 🙂.


  • I have found out that when putting
    --algorithm nscrypt
    no error message appears. The Hashrate is not affected however. :/

  • The scrypt-n error message is something I overlooked as the previously bundled miner for this algorithm labeled it that way, but the default ckolivas kernel is a scrypt kernel which it would have used if I'd correctly altered it to nscrypt instead. There's so much output on the miner I didn't spot the error message, just noticed it working!

    You're not doing anything wrong, unfortunately sgminer is primarily aimed at AMD cards and this algorithm in particular does really badly on nvidia cards. If you're using nvidia you'll need a version of ccminer to get the best hash rates, such as:

    I don't compile those however, as they require nvidia drivers which can be installed in various places on a system which makes linking the libraries unreliable and I don't have an nvidia card I could test against, so it would be a stab in the dark for me to do so.

  • Thanks for your quick response, Panda! 🙂
    I have run the same code on my iGPU (Radeon Pro 450 2 GB) which resulted in 64 KH/s.
    This underlines your statement.

    I will try compiling ccminer myself and post an update if it works.
    Again thanks for your support! 🙂

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file