Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Use Anonymous Ads

xmr-stak-amd for macOS: settings

Hi !
Thanks for your nice work...

I'm on a mac 5,1 with a fresh Radeon RX580, on 10.12.x
I got some questions:

  • I've tried the original settings. Around 300 H/S and Mac unusable as you said in other topics. With 1048 as difficulty, I can have 550 H/S. Mac unusable of course. With that in mind, do you think there would be a setting that allows me to use my mac (net, office and nothing fancy) while mining with my GPU ? For instance, If I mine Peercoins using GPU Miner, it does mine, around 1 GH/s and I can used my mac for simple operations.. (net, office, excel, etc...)

-75% of the time, after it said that I'm connected to the pool, I got the error "SOCKET ERROR - CALL error: Timeout while wang fr rpy. - Pool connection lost. waiting 10 s before retry (attempt 1). and of corse, no mining... I got understand why... (I'm mining on minergate right now... mainly because I'm used to mine there). The settings in config has no effect no this... (and of course it worked with the pool settings several times before that happens)

thanks for your time and knowledge !


  • ok I've noticed the error message stops after 3 or 5 minutes... mebbe it's from the pool ?

  • BTW, I've tried it on a mac Pro 2013 with two FirePro D300 and I can get it to work... it says that can't be open... Any change in the config got no effect no that...

  • xmr uses a really harsh mining algorithm so I doubt you can get it to leave you with a very usable computer if you're GPU mining. You can get away with CPU mining though and still maintain usability. Not sure what the problem with the pool is though, have you checked whether you have the same issue with other pools?

  • edited December 2017

    Hey FabulousPanda. If I'm using the compiled MacMiner app, does it by default do a 2% donation to the XMR stak developer or to you? If so, how can I turn it off? Thanks.

  • The XMR CPU miner in MacMiner is not the xmr-stak-cpu miner, it's an older one i forget from where! The separately compiled xmr-stak-amd has donations set to 0, the xmr-stak-cpu was compiled with donations left on to the original developer.

  • Hey FabulousPanda. How nice to get a reply from you. So I've tested both the CPU miner in MacMiner and the xmr-stak-cpu-MacOS. This is all for mining XMR on Mac CPUs, just hobby mining. I'm transitioning from MinerGate to supportXMR pool. I've definitely noticed better results on xmr-stak-cpu-MacOS versus the MacMiner GUI.

    Is it possible to config and turn off the 2% donations to the original developer in xmr-stak-cpu-MacOS? I would be comfortable making one time donations to both you and the original developer.

    Also, I noticed that the auto recommendation for cpu threads for the config file spit out two for me (0 and 1). That's what I'm using now, and it's still outperforming MacMiner. Activity Monitor says I'm using 200% of CPU power. Whereas if I tell MinerGate to use 4 cores, it uses 400% of CPU power. This is on a Mid 2014 MacBook Pro, but I'm also running on other computers.

    Is that auto recommendation of 2 threads instead of 3 or 4 to prevent damaging the computer? I'm planning on testing with 3 and 4 to see if there are any gains, but 2 threads seems to be working well now.

    Thanks for the hard work.

  • The miner in MacMiner is an older one forked from pooler's cpuminer which is why it slots nicely in to the app, xmr-stak uses a different conf setup hence not being in MacMiner. I might put together a GUI for XMR at some point as people seem to like it. I've no plans to go back to the two I compiled already but I will be compiling the replacement unified miner at some point - just finished an iOS app today though so I'm coded out for a couple of days.

    It must be guessing your core count wrong and giving you a setup for 2 cores, you can double your speed if you use all 4.

  • Sounds good FabulousPanda. I wish that I could turn off the 2% auto-donate in xmr-stak-cpu-MacOS, that would be my only request. Otherwise it works great. I've tested it using threads 0,1,2, and 3, and that did work.

    I tried running it on a 2008 MacBook Pro upgraded to El Capitan, but it did not work, I'll post the error later maybe. Have you tested it on older Macs? I'm going to try running MacMiner on the 2008 computer and see if I can get it to work.

    That's exciting about the iOS app! Are you going to be submitting it to the Apple Store?

  • I'll probably have a go at compiling xmr-stak for cpu only today and I'll set donations to 0 when I do.

    I don't think the xmr-stak-cpu version I compiled will work on older versions of macOS as it was compiled with libhttpd and that relies on something that wasn't previously available in the OS.

    The app was not crypto related, just a follow up to Where's the Meerkat called Where's the Unicorn - it's on the store for iPhone/iPad now. So if that's your kind of thing feel free to go unicorn hunting in the interim.

  • edited December 2017

    Any chance you got that xmr-stak-cpu complied with 0% donations? :-)

  • edited December 2017

    I tried to mine xmr on minergate pool but unfortunately had error (endless circle):
    Connecting to pool ...
    [2017-12-15 10:01:33] : Connected. Logging in...
    [2017-12-15 10:01:33] : Difficulty changed. Now: 1063.
    [2017-12-15 10:01:33] : New block detected.
    [2017-12-15 10:02:33] : SOCKET ERROR - CALL error: Timeout while waiting for a reply
    [2017-12-15 10:02:33] : Pool connection lost. Waiting 10 s before retry (attempt 1).

    ccminer is working fine at the same time with this pool.
    I'm using mac pro with d300 amd cards for xmr-stak-amd miner and ccminer for external GeForce 1080 card. Could you help me with correct settings for xmr-stak-amd miner for minergate pool?

    Best regards,


  • I've gotten the same error. Here's my advice -- don't use MinerGate. For anything. Find a new pool. They are not legit. Try supportXMR if you're looking to do XMR.

  • @timothy said:
    Any chance you got that xmr-stak-cpu complied with 0% donations? :-)

    I second this! Thanks FabulousPanda. This would be a big help.

  • Okay guys here it is, compiled from xmr-stak without httpd for 10.8+ and 0% donations

  • edited January 2018

    Hi! I need to change the pool... How can I do that after the first settings?

    OK with terminal ;) sorry

  • @FabulousPanda! You truly are fabulous! However, when I try to run xmr-stak on a iMac 2008 running El Capitan I get "Illegal instruction: 4" error. Seems it still has problems with older macOS versions, or?

  • @ChaotiX66 Thanks! I've been meaning to have a loot at compiling another xmr miner so I'll look in to that, which version are you trying to use though out of curiosity? I think I ran in to trouble getting it to compile with amd support for older systems.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file