"your miner was restarted automatically after a sudden stop"

New to MacMiner and running into this issue... this is the info I get before the error. Thanks!

[2017-07-23 20:39:19] Started bfgminer 5.4.2-unknown
[2017-07-23 20:39:19] Loaded configuration file /Users/r.schroeder/Library/Application Support/MacMiner/ltcurls.conf
[2017-07-23 20:39:19] CL Platform 0 vendor: Apple
[2017-07-23 20:39:19] CL Platform 0 name: Apple
[2017-07-23 20:39:19] CL Platform 0 version: OpenCL 1.2 (Apr 4 2017 19:07:42)
[2017-07-23 20:39:19] Platform 0 devices: 1
[2017-07-23 20:39:19] 0 GeForce GTX 1080 Ti
[2017-07-23 20:39:19] Unable to load ati adl library
[2017-07-23 20:39:19] Probing for an alive pool
[2017-07-23 20:39:19] Testing pool stratum+tcp://pool.vtconline.org:9171
[2017-07-23 20:39:50] Stratum authorisation success for pool 0
[2017-07-23 20:39:50] Stratum connection to pool 0 resumed
[2017-07-23 20:39:50] Pool 0 stratum+tcp://pool.vtconline.org:9171 alive
[2017-07-23 20:39:50] Pool 0 stratum+tcp://pool.vtconline.org:9171 alive
[2017-07-23 20:39:50] Network difficulty changed to 11.8k (84.78G)
[2017-07-23 20:39:50] New block: ...114cd64d5fba9660 diff 11.8k (84.78G)
[2017-07-23 20:39:50] Stratum from pool 0 detected new block
[2017-07-23 20:39:50] Error trying to wake notifier
[2017-07-23 20:39:50] Pool 0 is hiding block contents from us
[2017-07-23 20:39:50] Init GPU thread 0 GPU 0 virtual GPU 0
[2017-07-23 20:39:50] CL Platform vendor: Apple
[2017-07-23 20:39:50] CL Platform name: Apple
[2017-07-23 20:39:50] CL Platform version: OpenCL 1.2 (Apr 4 2017 19:07:42)
[2017-07-23 20:39:50] List of devices:
[2017-07-23 20:39:50] 0 GeForce GTX 1080 Ti
[2017-07-23 20:39:50] Selected 0: GeForce GTX 1080 Ti
[2017-07-23 20:39:50] initCl() finished. Found GeForce GTX 1080 Ti
[2017-07-23 20:39:50] API running in IP access mode on port 4052


  • You're trying to mine Vertcoin which uses the Scrypt-N algorithm with the Scrypt algorithm that was made for Litecoin. Switch the settings to Mine: VertCoin, Scrypt Adaptive-N.
  • Ah - of course! Now that I've changed that, what do you figure about this error...?

    [2017-07-31 09:50:57] /Applications/MacMiner.app/Contents/Resources/vertcgminer/bin/vertminer: -c: JSON decode of file '/Users/r.schroeder/Library/Application Support/MacMiner/vtcurls.conf' failed
    control character 0xd
  • It suggests either you haven't set up a pool for VTC or more likely there's something wrong with the configuration of it, a character that's breaking the parser. Try setting that up (again in necessary) and if it persists please post the contents of vtcurls.conf (less user/pass if you prefer leaving out the payout address)
  • Ah - opened up the conf file and it was pretty obvious what was wrong there.

    Almost there! Now I keep getting these messages with the "miner was suddenly restarted" error. I've tried a couple different pools; what's going on here?

    [2017-08-01 09:38:26] Started vertminer 0.5.4pre1
    [2017-08-01 09:38:26] Loaded configuration file /Users/r.schroeder/Library/Application Support/MacMiner/vtcurls.conf
    [2017-08-01 09:38:26] Probing for an alive pool
    [2017-08-01 09:38:26] Pool 0 difficulty changed to 61.561455
    [2017-08-01 09:38:27] Network diff set to 11K
    [2017-08-01 09:38:27] Stratum from pool 0 requested work restart

    Thanks for all the help!

  • Whoops sorry I forgot they kept changing the algorithm for VTC and to mine it SGMiner is the recommended tool, which doesn't typically play nice with macOS. I had a go at compiling it and got past a few issues but it seems as though my clang is acting up so I'll have to give it another go in a few weeks when I have a little more time.

  • Ah, gotcha. So really, no good way to mine VTC on OSX at the moment. What's the best way to be notified on your progress compiling SGMiner for OSX?

  • I'll come back here and let you know if I get it working, but I got past the compiler problem and found a couple of the kernels for the algorithm need updating to work for Mac and that's probably something I'd need to find someone else willing and capable to fix… I'll see whether I can get in touch with the original developer of Lyra2REv2 (the relevant algorithm) but I wouldn't get my hopes up.

  • I had to give up to find the answer as usual. I solved this problem 2 years ago with a different kernel and it wasn't merged in to the new ones! You can now GPU mine Vertcoin using this command line executable I will add to MacMiner in the near future: downloads.fabulouspanda.co.uk/sgminer-macOS.zip
    Instructions are contained :)

  • Nice!! Downloaded it and it seems to be running. I'm on a 1080ti, yet I only seem to be getting about 170Kh/s and am only getting messages about pool difficulty changes. Anything else I'm missing?

  • The text user interface allows you to change the intensity which is the main influence on hash rate, so either change it there or add the argument -I 11 (that's the letter I not the number 1) when you start the miner. The range of intensity can be set between 8 and 30, default will be 8 but if you set it too high your system may become unresponsive forcing you to hard restart so increase it in small increments to make sure you don't run in to that problem.

    You could also try the difference adding argument -w 64 changing to 128 or 256 and comparing the results. But Intensity alone will increase your hash rate a lot.

  • Ok thanks! I tried -w 64 and -I 20 in the screenshot I've attached, but still nothing... I tried anywhere from an intensity of 11 up to 22. At 22 I get about 6Mh/s, which still seems very low. Any other ideas...?
  • The Lyra2REv2 miner is very unstable, the VTC team are trying to find someone able to improve it but not having much luck. I'd switch to another coin if I were you… you're getting 100% HW with no accepted shares. I tested and it works fine with Decred and X11, probably most of the others. Just updated MacMiner so you can check out all the options in there.

  • Decred looks cool - I'll give that a spin. Thanks for all your help!

  • Starting up with Decred... mind if I ask a couple questions?

    Should I use sgminer in the terminal - I can't see a Decred option in Macminer? I also see there is a compile of ccminer for osx - would this be better?

    I tried running sgminer using this command (I've obviously signed up for an account at suprnova), but I don't seem to be getting anywhere...

    ./sgminer -o stratum+tcp://dcr.suprnova.cc:3256 -u UserLogin.WorkerName -p password

  • If you don't see Decred in MacMiner you need to get the new version from the download page or just use the standalone sgminer binary. I don't think ccminer has been compiled for macOS in 3-4 years so there wouldn't be a VTC/Decred version available but if there is you would be better off with that on an nvidia card. I gave compiling it a shot briefly but my startup SSD died the other day and I didn't want to mess with anything on my backup system before my primary is up and running again. I don't have anything nvidia to test against either!

    You're missing the algorithm at the command line, add -k Decred

  • Ah - of course. Working at the command line now so I'm happy with that. Thanks!

  • Hi! One more question for ya - mining decred is going very well btw. How do I get sgminer to automatically use dynamic intensity when it starts, so I don't have to change the option after every time I launch it? It's not saved in the config file, and I've tried launching with ./sgminer -I d but, while that launches, it's still starting with 8 (whereas if I do it once it's launched, I'm closer to 20).


    Also - now that I think of it - would you have a decred wallet you recommend? I setup the Decredition wallet and it generated an address I'm currently mining to, but that seems to be gone. So I guess two questions if you'd know the answer - how can I add my address to a wallet, and which wallet would you suggest? (I do have the seed and password for my address, of course).

  • According to ./sgminer --help what you've done would be the way to go, I think you're probably best off setting the intensity to 20 if that's where you want it by -I 20 flag.

    What do you mean your address seems to be gone? I think it's probably more likely not visible in the wallet. Once you generate a receiving address it will work with your private key forever unless it's VERY different to Bitcoin. I don't have any experience with Decred personally, beyond testing MacMiner, so I'd recommend using Decredition downloaded from https://www.decred.org

    There doesn't seem to be a great deal of support available for it directly beyond GitHub, I guess the most useful thing I could say would be to ask at https://forum.decred.org

  • Cool - thanks! I'll check into the forum there.

    Weird with sgminer - even if I launch with -I 20, it still launches with an intensity of 8. I guess the flag doesn't work at all.

  • edited September 2017

    That's weird. It works in MacMiner which uses the -I flag. Just to be sure, you are using a capital i and not L right? You could also try --intensity 20 (that's with two dashes, formatting makes it look like a long dash) and if you're using a .conf file check it doesn't contain an intensity value.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file