FPG MacMiner

I finally got it to work speeds go up and down using macminer FPG face. So after two days of mining I decided to switch pools and I got this message  [2015-05-27 19:38:31] /Applications/MacMiner.app/Contents/Resources/bfgminer/bin/bfgminer: -c: JSON decode of file '/Users/Library/Application Support/MacMiner/bfgurls.conf' failed

 unexpected newline

Than another time I tried I got same thing but my worker id was listed in there. Maybe bad miner ? 


  • For some reason this file has become formatted incorrectly, I would appreciate it if you'd PM me the file

    /Users/yourusername/Library/Application Support/MacMiner/bfgurls.conf

    You can delete it if you like but running the pool set up again is easier, look out for any special characters in the pool, username or password which might be interpreted as JSON formatting
  • note it is not necessary to include http:// or stratum+tcp:// in the pool address, they are not necessary to make it connect to the pool but sometimes used to choose whether to use stratum or GBT to mine. It will auto detect whatever works.
  • I left username out because it had my name so I didn't want it posted here                                                       [2015-05-27 20:25:52] /Applications/MacMiner.app/Contents/Resources/bfgminer/bin/bfgminer: -c: JSON decode of file '/Users/MyUserName/Library/Application Support/MacMiner/bfgurls.conf' failed

     unexpected newline

    I don't know how to pm you but i took out the http:// and stratum+tcp://     and still the same so do I delete program I'm using the 1.25b macminer on macbook pro
  • post the pool address here and make sure the username and password are only made of letters, numbers, and perhaps a full stop if necessary e.g. 

    If setting up the pool still doesn't work click 'run old pool setup' in the prefs and run it that way, or in Finder alt-shift-G or 'Go' menu -'Go to folder' and paste
    ~/Library/Application Support/MacMiner
    click go

    you'll see the file, you can open it and see what looks wrong or just post it here with the user/pass deleted
  • I see two files bfgurls.conf and ltcurls.conf. On both saved logs it had same user and pass for both and it's not so pose to be like that.

    bfgurls.conf =

    "pools" : [
    "url" : "us-east.multipool.us:8888
    "user" : "     ",
    "pass" : "   "



    "pools" : [
    "url" : "stratum+tcp://scrypt.eobot.com:4334",
    "user" : "       ",
    "pass" : "  "

  • Definitely buggy, not sure why it saved both the same, did you use the pool setup in the Preferences pane or the old one that open from a button? 

    I'd say delete those files and set it up again but the problem is probably the new line after the BTC pool and the closing quote.

    You also have to be very careful if you edit the file manually that autocorrect doesn't replace a normal double quote " for a  “Curly style quote” - subtle appearance difference but that can break it too
  • edited May 2015
    I open than click view open FPGA/Miner than click the gear thing under start. Than i click edit pool settings and copy and paste the settings to the preference box that appears that shows set up a pool for SHA.

    Than pool, username,pass than save. than i get this:         /Applications/MacMiner.app/Contents/Resources/bfgminer/bin/bfgminer: -c: JSON decode of file '/Users/MyuserName/Library/Application Support/MacMiner/bfgurls.conf' failed

     unexpected newline

    How do I fix the newline thing I deleted the files but same thing.

    Also do you know the steps on how to install the antimatter U3 I think everyone has a problem with this miner but get it to work. The highest i got it up to just by plugging it in and copy paste settings in preferences up to 50 to 54ghs it still not the highest it can go to but i was little okay with it. Because I was thinking maybe the labs or server that I downloaded might be in the way but it worked before so I don't know.
  • edited May 2015
    Try clicking Edit config manually instead of Edit pool settings and paste this in


    "pools" : [


    "url" : "stratum+tcp://me.pool:3334",

    "user" : "1M3F5DR4vApgHqsAJ6U1HE4HNEjo7Pm52j",

    "pass" : "1M3F5DR4vApgHqsAJ6U1HE4HNEjo7Pm52j"




    with your information then click save. The new line probably comes from copying and pasting the pool address with an invisible enter/new line character in the paste for the pool so you could also probably fix it by typing the info for the pool manually rather than copying and you won't have to be careful about curly quotes in the manual config

  • edited May 2015
    actually don't copy and paste that, the forum software is adding new lines as well :/ Just type the pool in instead of pasting it

    edit: managed to format it so you CAN copy/paste, but still, try the other way first
  • Ok i got it to work, How it worked was to make both sides save as blank so delete everything save both sides close program reopen than type manually in edit config because I couldn't get the spaces right even after copy and edit save to manually config. 

    It would be nice if you could add a button on the GUI so you could adjust speeds easily if they're not set right or going the maxium speed.  

    Thank you for the help 
  • If you're using an FPGA or ASIC only some types support adjusting the hash rate - which is done indirectly by altering things called Frequency and Voltage of the chips that are doing the mining. However, I'm afraid MacMiner is unlikely to see future updates unless someone else creates a pull request on the github or it's a really minor fix

  • Now I kind of stopped mining for a awhile but later started back up everything was fine. So one day I DL the new Mac EL Captain update everything seems fine with my mac long story short I decide to mine today and I get this 

    [2015-11-04 00:13:38] Timers: Using gettimeofday

     [2015-11-04 00:13:38] Global quota greatest common denominator set to 1

     [2015-11-04 00:13:38] setrlimit: Changed soft fd limit from 2560 to 1024 (FD_SETSIZE=1024; hard limit=unlimited)

    Do you know why maybe this happen ?  Also the 1.5 wouldn't stay open after this message to so i DLded the new macminer it stays open but I get the same thing above.

  • Pretty sure a USB driver issue resulting from OS upgrade, try using the cgminer window or reinstalling the necessary drivers for your miner(s)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file