background

R-Box on macminer

Just got this r-box and trying to get it to mine on macminer. Have a thought time. Keeps saying that the executive lock is on. Does anyone know if macminer supports the rockminer
«1

Comments

  • Been talking to some friends that have also bought these rock miners. Seem to be a interest in these little boxes. I hope that man miner will find a way to support in the future.
  • Try adding

    -S rockminer:all

    To the manual flags section of the FPGA/ASIC Miner preferences panel

    It should work right now…
  • Thank you that is great I'll try//

  • here is what I getting . 

    [2014-07-04 05:10:32] hidapi_try_lib: Couldn't load libhidapi-0.dylib: dlopen(libhidapi-0.dylib, 2): image not found

     [2014-07-04 05:10:32] hidapi_try_lib: Couldn't load libhidapi-hidraw.dylib: dlopen(libhidapi-hidraw.dylib, 2): image not found


    ry lock on /dev/cu.SLAB_USBtoUART


     [2014-07-04 05:10:32] Acquired exclusive advisory lock on /dev/cu.SLAB_USBtoUART

     [2014-07-04 05:10:32] rockminer: Successfully opened /dev/cu.SLAB_USBtoUART


     [2014-07-04 05:10:32] rockminer: Successfully opened /dev/cu.SLAB_USBtoUART

     [2014-07-04 05:10:32] rockminer: Short read from /dev/cu.SLAB_USBtoUART (0)


     [2014-07-04 05:10:32] rockminer: Short read from /dev/cu.SLAB_USBtoUART (0)

     [2014-07-04 05:10:32] No devices detected!


     [2014-07-04 05:10:32] No devices detected!

     [2014-07-04 05:10:32] Waiting for devices


     [2014-07-04 05:10:32] Waiting for devices

     [2014-07-04 05:10:32] Probing for an alive poolI


    I have tried with all the boxed checked in the auto detect, and with all the boxed unchecked. also tried with the Stratum site and the regular Http..

    I know I'm new to this  and hop that i'm not to much of a pain....

    Thanks 

  • Started bfgminer 4.3.0

     [2014-07-04 05:20:11] Loaded configuration file /Users/romulus/Library/Application Support/MacMiner/bfgurls.conf


     [2014-07-04 05:20:11] Loaded configuration file /Users/romulus/Library/Application Support/MacMiner/bfgurls.conf

     [2014-07-04 05:20:16] No devices detected!


     [2014-07-04 05:20:16] No devices detected!

     [2014-07-04 05:20:16] Waiting for devices


     [2014-07-04 05:20:16] Waiting for devices

     [2014-07-04 05:20:16] Probing for an alive pool


     [2014-07-04 05:20:16] Probing for an alive pool

     [2014-07-04 05:20:16] Testing pool http://api.bitcoin.cz:8332

     [2014-07-04 05:20:17] JSON-RPC call failed: {

       "code": -1,

       "message": "Unsupported method 'getblocktemplate'"

    }

     [2014-07-04 05:20:17] Testing pool 0 stratum stratum+tcp://stratum.bitcoin.cz:3333

     [2014-07-04 05:20:17] Switching pool 0 http://api.bitcoin.cz:8332 to stratum+tcp://stratum.bitcoin.cz:3333


     [2014-07-04 05:20:17] Switching pool 0 http://api.bitcoin.cz:8332 to stratum+tcp://stratum.bitcoin.cz:3333


  • You have the silabs driver installed righ? What changed between the first one and the second one?
  • This issue it turns out is extensively discussed here


    Unfortunately the only possible solution I can see is to keep trying again until it works, or wait for a software update. Condolences!
  • edited July 2014
    I'm really new to mining... and I have no real idea what you're talking about.. I'lll read the thread and try to figure out??/ I bought a antminer and have been using that in asteroid for about a week.. could this be the conflict
    ? but Ill read a search more that for point me in the right directions
    R
  • Asteroid messes with the Mac OS drivers so it could be a conflict, try without that open or after restarting the machine - the problem I was linking to seems to be that a lot of the time it doesn't work, but if you keep trying sometimes it will start.
  • Cool Thanks...I know I learning, but not giving up. 

  • I have to say this is a great place for newbies to come to, and learn
    thanks all

  • more on my trek into Mining
    I have Unintalled Asteroid and removed all the associated files( at least I hope) 
    shut down my Mac Pro/ removed  Ant miner and removed a Bluetooth USB attachment
    Back up... plugged in Rockminer  did a system test and got this for my USB Mark for my Rockminer

    CP2102 USB to UART Bridge Controller:


      Product ID: 0xea60

      Vendor ID: 0x10c4  (Silicon Laboratories, Inc.)

      Version: 1.00

      Serial Number: 0001

      Speed: Up to 12 Mb/sec

      Manufacturer: Silicon Labs

      Location ID: 0x1d100000 / 2

      Current Available (mA): 500

      Current Required (mA): 100

      not sure if this incorrect ( silicon labs)?
  • Still didn't show up in macminer
    frustrating... 

  • As far as I know Asteroid only disables the drivers while it's running so you should be fine!

    in Terminal run

    ls -l /dev/cu*

    and the device will show up there. I think it's right already
  • Oh and did you add the manual flags
    -S rockminer:all

    ?
  • Yes..
    join to try the terminal mode

    [xxxxxc:~] xxxxx% ls -l /dev/cu*

    crw-rw-rw-  1 root  wheel   33,   1 Jul  5 12:14 /dev/cu.Bluetooth-Incoming-Port

    crw-rw-rw-  1 root  wheel   33,   3 Jul  5 12:14 /dev/cu.Bluetooth-Modem


    Yes I have in the flags -S rock miner:all

    also I uninstalled Macminer and reinstalled... 

    I'm trying.. I have learned a lot. never been in terminal mode... thanks



  • your rock miner isn't showing up there. we can't get it working without that - first power off, unplug usb, plug in again and run the terminal command again. if that doesn't work, try reinstalling the silabs driver and give it another shot.
  • oh and it's probably just auto correct but rockminer needs to be one word in -S rockminer:all
  • I never install the slabs drivers? was part of another program? 
    Could I have deleted that file .. when  uninstalling?

  • I went to Silicon lad and  downloaded the drivers.. and now trying to install and will do the process

  • Yea! partial success 

    bigboymac:~] romulus% ls -l /dev/cu*

    crw-rw-rw-  1 root  wheel   33,   3 Jul  5 13:18 /dev/cu.Bluetooth-Incoming-Port

    crw-rw-rw-  1 root  wheel   33,   5 Jul  5 13:18 /dev/cu.Bluetooth-Modem

    crw-rw-rw-  1 root  wheel   33,   1 Jul  5 13:18 /dev/cu.SLAB_USBtoUART

  • ok that's what we wanted to see, now you can run

    -S rockminer:/dev/cu.SLAB_USBtoUART
  • Making the assumption that I should run this in the manual flags command line ?

  • 2014-07-05 13:31:15] Loaded configuration file /Users/romulus/Library/Application Support/MacMiner/bfgurls.conf

     [2014-07-05 13:31:19] No devices detected!


     [2014-07-05 13:31:19] No devices detected!

     [2014-07-05 13:31:19] Waiting for devices


     [2014-07-05 13:31:19] Waiting for devices

     [2014-07-05 13:31:19] Probing for an alive pool


     [2014-07-05 13:31:19] Probing for an alive pool

     [2014-07-05 13:31:19] Testing pool http://api.bitcoin.cz:8332

     [2014-07-05 13:31:20] JSON-RPC call failed: {

       "code": -1,

       "message": "Unsupported method 'getblocktemplate'"


  • try -S rockminer:all and give it a few restarts, stopping a few seconds in between, as the rockminer is apparently a bit sticky. 

    I'd be interested to know whether running

    sudo chmod 777 /dev/cu.SLAB*

    in Terminal helps matters
  • I have tried 10 time with 

    -S rockminer:/dev/cu.SLAB_USBtoUART( copied and pasted from Flag window_

    AND 

    -S rockminer:all

     and to date no devices found..  


    Is there a way to check is the  rock miner is bad?

  • I put in an Antminer and is was seen right away and is mining? 

  • yeah it's an issue with bfgminer and the rbox and unfortunately no-one is quite sure what's causing it, not even sure whether it affects all users or not. did you try the running the chmod command? The problem is to do with not getting the response back so it's been speculated that it could be about read permissions and chmod changes that.

Leave a Comment

Drop image/file