background

I have a (Wall Mounted Display) Mac Mini that I hoped to sling a GridSeed Unit off and Scrypt Mine

edited April 2014 in General
Sadly the unit is NOT upgradeable software wise -- I'm stuck at 10.6 on that unit. 

  Model Name: Mac mini

  Model Identifier: Macmini1,1

  Processor Name: Intel Core Duo

  Processor Speed: 1.66 GHz

  Number Of Processors: 1

  Total Number Of Cores: 2

  L2 Cache: 2 MB

  Memory: 2 GB

  Bus Speed: 667 MHz

  Boot ROM Version: MM11.0055.B08

  SMC Version (system): 1.3f4


I have not had much luck finding let along running anything that either


  • Works
  • Recognizes the GridSeed Unit


I do not need a GUI - more than happy to work in terminal but this unit does NOT have XCode and it can no longer be gotten, HomeBrew and git won't install properly as a result so I'm pretty much stuck with pre-compiled binaries. Seems like by the time I find one old enough to run on the machine it's too old to have any knowledge of GridSeed. 


Any options or suggestions? 


I really don't like the thought of having just bought a $200 paperweight... 


Tagged:

Comments

  • Update -- I have the GridSeed device working on my "big" mac so I know what is required to have a working unit at this point. 

    Thanks to this page: 


    The "trick" seems to be to get the grid seed enabled version of MacMiner, copy it over to /Applications, drill do via the command line to: 

    • /Applications/MacMiner-GridSeed.app/Contents/Resources/gridseedcpu4/bin

    Note - I renamed by "app" so I could tell it apart form the "normal" version. 

    The magical incantation that finally worked (for me -- your mileage will of course vary) was:

    • ./minerd  -o stratum+tcp://multi.ghash.io:3333 -u techmag.7 --freq=850 -G /dev/cu.usbmodem5d11


    According to GHASH.io I'm running about 325(isn) khs 

    Yahoo! -- I'll be a CryptoBillionaire in no time flat! :)

    Now - I figured I could just move this over to the MacMini and get this noisy contraption off my desk and yet on that box the problem appears to be: 

    Gary-Hewetts-Mac-mini:bin garyhewett$ ./minerd  -o stratum+tcp://multi.ghash.io:3333 -u techmag.8 --freq=850 -G /dev/cu.usbmodem5d11
    -bash: ./minerd: Bad CPU type in executable

    Sigh :( 

    Macs are supposed to be easy -- right? 

    Anyone got a clue as to what is next? 
  • I think I need a 32-bit compiled version of minerd but one that is of course compiled to handle gridseed. Any suggestions on how/where that might be found? 
  • I'll have to compile a new 32bit version and just hope it works with 10.6! I'll update you here
  • Have you tried booting the 64bit EFI? Apple locks Snow Leopard into 32bit mode for device compatability on some hardware but 64bit app code should work just fine.

    read this:

    http://www.ahatfullofsky.comuv.com/English/Programs/SMS/SMS.html

Leave a Comment

Drop image/file