background

Antminer U3 + 5 Antminer U2

edited March 2015 in Support
I was running 5 of the U2s using the FPGA/ASIC miner. I just bought a U3 as an upgrade. I looked at some of the other posts on using CGMiner with the U3, but CGMiner never seemed to see it.

What I tried...

  • Removed SiLabs drivers for the U2s
  • Restarted
  • Fired up CGMiner with this string (from BitMain) in the window:
    • --bmsc-options 115200:0.54 –o 50.31.149.57:3333 -u antminer -p 123 --bmsc-voltage 0830 --bmsc-freq 0982 --startdiff 6
It never started hashing. I went hunting for something to tell me what the different switched actually meant, but couldn't find anything. The IP address should probably go, though I really have no idea. I'll continue fiddling, and posting here, but any suggestions are welcome. :-)

Ideally, I'd like to use them all together, but it looks like that is unlikely. :-/
«13

Comments

  • Hah. Duh. -o is the Pool, -u is the username, -p is the password?

  • hmmm few problems here, first off are you using Bitmain's version of cgminer, an official version you compiled yourself or the version in MacMiner? You have the -o -u -p right though :)

    From what I understand Bitmain's version REQUIRES the silabs driver which is almost certainly opposite to the requirements of official cgminer versions - it is for every other device I've come across.

    If you still have the drivers uninstalled try running the cgminer window of MacMiner or an original non bitmain version and it should be detected automatically. If you use those set voltage and frequency like this:

    --au3-freq <arg>    Set AntminerU3 frequency in MHz, range 100-250 (default: 225.0)
    --au3-volt <arg> Set AntminerU3 voltage in mv, range 725-850, 0 to not set (default: 750)
  • I'm just using the version in MacMiner. So, the "bmsc" switches are for their "special" version, and the au3 are for the official versions? They are setting the voltage to 0800 & freq to 1306 in their manual, the frequency is out of the range you suggested.
  • I just killed the SILabs drivers again, and changed the settings to au3. Now I get this - no detection:

     [2015-03-08 19:00:45] Started cgminer 4.9.1

     [2015-03-08 19:00:45] Loaded configuration file /Users/scook/Library/Application Support/MacMiner/bfgurls.conf

     [2015-03-08 19:00:56] No devices detected!

     [2015-03-08 19:00:56] Waiting for USB hotplug devices or press q to quit

     [2015-03-08 19:00:56] Probing for an alive pool

     [2015-03-08 19:00:57] Pool 0 difficulty changed to 128.0

     [2015-03-08 19:00:57] Network diff set to 47.4G

     [2015-03-08 19:00:45] Started cgminer 4.9.1                    

     [2015-03-08 19:00:45] Loaded configuration file /Users/scook/Library/Application Support/MacMiner/bfgurls.conf                    

     [2015-03-08 19:00:56] No devices detected!                    

     [2015-03-08 19:00:56] Waiting for USB hotplug devices or press q to quit                    

     [2015-03-08 19:00:56] Probing for an alive pool                    

     [2015-03-08 19:00:57] Pool 0 difficulty changed to 128.0                    

     [2015-03-08 19:00:57] Network diff set to 47.4G                    

    (5s):0.000 (1m):0.000 (5m):0.000 (15m):0.000 (avg):0.000h/s          

     [2015-03-08 19:01:02] API running in IP access mode on port 4048 (25)

     [2015-03-08 19:01:02] API running in IP access mode on port 4048 (25)                    

    (5s):0.000 (1m):0.000 (5m):0.000 (15m):0.000 (avg):0.000h/s          

    (5s):0.000 (1m):0.000 (5m):0.000 (15m):0.000 (avg):0.000h/s          

  • yes bmsc must stand for bitmain special controls because it's not supported outside of their own mods :P It should work if you just start mining in the cgminer window or at the command line with the bundled cgminer from the latest version of MacMiner but keep in mind some devices only look for a controller for the first short time period after they're plugged in - try replugging after starting cg or immediately beforehand.

    Check the manual again - it gives the actual frequency referred to by the value you're quoting, which maps to 243.75MHz

  • Ah, so theirs is a mapped value rather than the actual freq. Silly people. 

    I corrected that & fiddled with the plugs. I also tried leaving off the -o -u -p switches to let it use the MacMiner settings ... it gave some different errors that way:

     [2015-03-08 19:13:19] No devices detected!                    

     [2015-03-08 19:13:19] Waiting for USB hotplug devices or press q to quit                    

     [2015-03-08 19:13:19] Probing for an alive pool                    

     [2015-03-08 19:13:19] Pool 0 difficulty changed to 128.0                    

     [2015-03-08 19:14:19] No servers were found that could be used to get work from.                    

     [2015-03-08 19:14:19] Please check the details from the list below of the servers you have input                    

     [2015-03-08 19:14:19] Most likely you have input the wrong URL, forgotten to add a port, or have not set up workers                    

     [2015-03-08 19:14:19] Pool: 0  URL: stratum+tcp://stratum.mining.eligius.st:3334  User: 17FoLXzFo63t1m8DGcXrwhNrS3nR3tsBeB  Password: 17FoLXzFo63t1m8DGcXrwhNrS3nR3tsBeB                    

     [2015-03-08 19:14:19] No servers could be used! Exiting.

  • Still no detection though. :-( Maybe I got a bad one. Time to swap the USB cable & see if it's that. :)
  • enter the pool like stratum.mining.eligius.st:3334, it doesn't like the stratum+tcp:// prefix

    do you have any manual flags set in macminer?

    Could be worth trying with the silabs drivers, I'm pretty sure I read about experimental support for using either method, plus there's a patch to bfgminer on github which apparently supports it with the drivers.
  • Alas, it wasn't the USB cable. :) 

    My CGMiner options dialog is just:
    —au3-voltage 0800 —au3-freq 243.75

    I changed the pool info as you suggested as well. Of course that didn't help detection, but it get rid of the pool error. :)
  • try quitting MacMiner, open Terminal and run these two commands

     sudo kextunload -b com.apple.driver.AppleUSBCDC
    sudo kextunload -b com.apple.driver.AppleUSBCDCACMData

    Then open and give it another shot - If that doesn't work try running from the command line again using sudo so it runs as superuser, cgminer github says that may be necessary for some devices... a cgminer specific issue I think.
  • Oh, a side issue, the manual flags don't seem to be sticking when I quit MacMiner & go back in. Corrupt prefs perhaps?

  • Note those commands unload some apple USB drivers but restarting the computer brings them back, as does

     sudo kextload -b com.apple.driver.AppleUSBCDC
    sudo kextload -b com.apple.driver.AppleUSBCDCACMData
  • Should I unload the Apple drivers after reinstalling the SILabs drivers?
  • No, if you've installed those there's no point unloading these unless you unload those too. cgminer had a big options change a while back and because of issues like these I've tended to prefer and primarily support bfgminer so when the changes happened I just ripped out most of the prefs interface, I guess I didn't hook up the manual flags!
  • Thanks for the bug report, it seems the manual flags aren't connected at all, not even just not saving. I'll fix it when I update bfgminer to 5.1
  • Hahah. I find the weirdest things. ;)

    Weird, tried this:
    sudo ./cgminer -o stratum.mining.eligius.st:3334 -u 17FoLXzFo63t1m8DGcXrwhNrS3nR3tsBeB -p 17FoLXzFo63t1m8DGcXrwhNrS3nR3tsBeB —au3-voltage 0800 —au3-freq 243.75

    Got:
     [2015-03-08 22:26:05] Unexpected extra commandline arguments

    Ooops. Looks like my -- got converted to — at some point. stupid TextEdit.

    Trying:
    sudo ./cgminer -o stratum.mining.eligius.st:3334 -u 17FoLXzFo63t1m8DGcXrwhNrS3nR3tsBeB -p 17FoLXzFo63t1m8DGcXrwhNrS3nR3tsBeB --au3-volt 0800 --au3-freq 243.75

    Interesting:
     [2015-03-08 22:31:37] ./cgminer: --au3-volt: '0800' is not a number 

    This is bizarre. :)

    It didn't like the leading zero. Picky, picky. :-D
    sudo ./cgminer -o stratum.mining.eligius.st:3334 -u 17FoLXzFo63t1m8DGcXrwhNrS3nR3tsBeB -p 17FoLXzFo63t1m8DGcXrwhNrS3nR3tsBeB --au3-volt 800 --au3-freq 243.75

    Still no detection, but it sort of shows. When I list the USB devices I get:
    Bus 61 Device 2 ID: 10c4:ea60 Silicon Labs CP2102 USB to UART Bridge Controller inactive

    So, I guess I do need the SILabs drivers?
  • With the SILabs drivers this is the MacMiner result:

    [2015-03-09 00:22:33] Started cgminer 4.9.1

     [2015-03-09 00:22:33] Loaded configuration file /Users/scook/Library/Application Support/MacMiner/bfgurls.conf

     [2015-03-09 00:22:34] blockerupter detect (61:2) failed to initialise (incorrect device?)

     [2015-03-09 00:22:34] Blockerupter usb init failed

     [2015-03-09 00:22:35] Icarus detect (61:2) failed to initialise (incorrect device?)

     [2015-03-09 00:22:35] Icarus detect (61:2) failed to initialise (incorrect device?)

     [2015-03-09 00:22:35] No devices detected!

     [2015-03-09 00:22:35] Waiting for USB hotplug devices or press q to quit

     [2015-03-09 00:22:35] Probing for an alive pool

     [2015-03-09 00:22:36] Pool 0 difficulty changed to 128.0

     [2015-03-09 00:22:36] Network diff set to 47.4G

     [2015-03-09 00:22:33] Started cgminer 4.9.1                    

     [2015-03-09 00:22:33] Loaded configuration file /Users/scook/Library/Application Support/MacMiner/bfgurls.conf                    

     [2015-03-09 00:22:34] blockerupter detect (61:2) failed to initialise (incorrect device?)                    

     [2015-03-09 00:22:34] Blockerupter usb init failed                    

     [2015-03-09 00:22:35] Icarus detect (61:2) failed to initialise (incorrect device?)                    

     [2015-03-09 00:22:35] Icarus detect (61:2) failed to initialise (incorrect device?)                    

     [2015-03-09 00:22:35] No devices detected!                    

     [2015-03-09 00:22:35] Waiting for USB hotplug devices or press q to quit                    

     [2015-03-09 00:22:35] Probing for an alive pool                    

     [2015-03-09 00:22:36] Pool 0 difficulty changed to 128.0                    

     [2015-03-09 00:22:36] Network diff set to 47.4G                    

    (5s):0.000 (1m):0.000 (5m):0.000 (15m):0.000 (avg):0.000h/s          

     [2015-03-09 00:22:41] API running in IP access mode on port 4048 (25)

     


    In a loop. Forever. :) The command line does the same.

  • Keeping the driver installed you should be able to get 4GH/s out of it with bfgminer (the ASIC window) but I don't believe anyone has got it running at full speed with the released version - but if you compile a version with this pull it will probably work properly:


    I imagine full support will be in 5.2, though that that's much help now! But at least you can figure out whether the device is working. I think the blockerupter/icarus detect is it detecting it as the wrong device, which makes me suspect that it does work and if you had all the relevant drivers unloaded it should work in cgminer. The command below probably unloads all the relevant ones and one or two that won't actually be installed (but may be) - run this with MacMiner closed then open it and try cgminer

     sudo kextunload -b Library/Extensions/SiLabsUSBDriver.kext && sudo kextunload -b Library/Extensions/SiLabsUSBDriver64.kext && sudo kextunload -b Library/Extensions/FTDIUSBSerialDriver.kext && kextunload -b com.silabs.driver.CP210xVCPDriver && kextunload -b com.silabs.driver.CP210xVCPDriver64 && kextunload -b com.FTDI.driver.FTDIUSBSerialDriver && kextunload -b com.silabs.driver.CP210xVCPDriver && kextunload -b com.silabs.driver.CP210xVCPDriver64 && kextunload -b com.FTDI.driver.FTDIUSBSerialDriver && kextunload -b Library/Extensions/SiLabsUSBDriver.kext && kextunload -b Library/Extensions/SiLabsUSBDriver64.kext && kextunload -b Library/Extensions/FTDIUSBSerialDriver.kext
  • Please try this version which includes bfgminer compiled from the not yet released source on github


    It's only been tested on Linux, but as Mac OS has many similarities it should work here too. Just plug in and start up the FPGA/ASIC window - let me know how it goes!
  • Oooo. Good start:

     [2015-03-21 19:32:01] AMU 2: Opened /dev/cu.SLAB_USBtoUART13

     [2015-03-21 19:32:01] AMU 4: Opened /dev/cu.SLAB_USBtoUART14

     [2015-03-21 19:32:01] AMU 0: Opened /dev/cu.SLAB_USBtoUART15

     [2015-03-21 19:32:01] AMU 1: Opened /dev/cu.SLAB_USBtoUART16

     [2015-03-21 19:32:01] AMU 3: Opened /dev/cu.SLAB_USBtoUART

     [2015-03-21 19:32:01] AMU 5: Opened /dev/cu.SLAB_USBtoUART17


    That's the U3 & the U2s. Giving it a minute to get going & see what the rate is.

  • Great news! Thank you for coming back to help us out :)
  • My old rate was around 10 Gh. Without changing settings it seems to be settling in at about 15.5Gh. Of course that's with my old manual flag set too...

    --set-device antminer:clock=x0B01

    I'm about to stop it & clear out the manual flags.

    Odd, while I was typing this, the rate just dropped to 3 Gh, then started climbing back up again. The accepted count reset too. (I think this might have been happening before with 1.5.24 too, but I never watched it closely).


    Oh, by the way, it's awesome that mobile miner seems to be hooked back up. 1.5.25 made my box show up in it for the first time. :-)
  • That's better. Dumped that manual flag string & Mobile Miner shows ~26Gh (Mac Miner still shows 8-10Gh). I'm still only getting ~15Gh out of the U3, so I'll probably need a manual flag to get the clock speed up. But this is definitely better than it sitting there, doing nothing. ;)

    Hmmm ... maybe it's just warming up. Or something. It got up to ~30Gh for the U3 & 40 total for a sec. And MacMiner showed the right rate too. Now it seems to have gone zombie.

    In fact after restarting everything (except the computer), MacMiner starts, then stops on its own.
  • Hmmm. It's still just stopping on me. (even after a complete reboot) Strange.

     [2015-03-21 20:13:49] Started bfgminer 5.1.0-34-ga0fb134


     [2015-03-21 20:13:49] Started bfgminer 5.1.0-34-ga0fb134

     [2015-03-21 20:13:49] Loaded configuration file /Users/scook/Library/Application Support/MacMiner/bfgurls.conf


     [2015-03-21 20:13:49] Loaded configuration file /Users/scook/Library/Application Support/MacMiner/bfgurls.conf

     [2015-03-21 20:13:50] Found AMU 0 at /dev/cu.SLAB_USBtoUART2

     [2015-03-21 20:13:50] Found AMU 1 at /dev/cu.SLAB_USBtoUART1

     [2015-03-21 20:13:50] Found AMU 2 at /dev/cu.SLAB_USBtoUART4

     [2015-03-21 20:13:50] Found AMU 3 at /dev/cu.SLAB_USBtoUART5

     [2015-03-21 20:13:50] Found AMU 4 at /dev/cu.SLAB_USBtoUART

     [2015-03-21 20:13:50] Found AMU 5a at /dev/cu.SLAB_USBtoUART3

     [2015-03-21 20:13:50] Probing for an alive pool


     [2015-03-21 20:13:50] Probing for an alive pool

     [2015-03-21 20:13:50] Testing pool stratum+tcp://stratum.mining.eligius.st:3334

     [2015-03-21 20:13:51] Stratum authorisation success for pool 0

     [2015-03-21 20:13:51] Pool 0 stratum+tcp://stratum.mining.eligius.st:3334 alive


     [2015-03-21 20:13:51] Pool 0 stratum+tcp://stratum.mining.eligius.st:3334 alive

     [2015-03-21 20:13:51] Network difficulty changed to 47.4G (339.5P)


     [2015-03-21 20:13:51] Network difficulty changed to 47.4G (339.5P)

     [2015-03-21 20:13:51] New block: ...7a528f759d679cf2 diff 47.4G (339.5P)

     [2015-03-21 20:13:51] Stratum from pool 0 detected new block


     [2015-03-21 20:13:51] Stratum from pool 0 detected new block

     [2015-03-21 20:13:51] Pool 0 is hiding block contents from us


     [2015-03-21 20:13:51] Pool 0 is hiding block contents from us

     [2015-03-21 20:13:51] API running in IP access mode on port 4028


     [2015-03-21 20:13:51] API running in IP access mode on port 4028

     [2015-03-21 20:13:51] AMU 0: Opened /dev/cu.SLAB_USBtoUART2

     [2015-03-21 20:13:51] AMU 2: Opened /dev/cu.SLAB_USBtoUART4

     [2015-03-21 20:13:51] AMU 3: Opened /dev/cu.SLAB_USBtoUART5

     [2015-03-21 20:13:51] AMU 4: Opened /dev/cu.SLAB_USBtoUART

     [2015-03-21 20:13:51] AMU 1: Opened /dev/cu.SLAB_USBtoUART1

     [2015-03-21 20:13:51] AMU 5: Opened /dev/cu.SLAB_USBtoUART3

     [2015-03-21 20:13:51] New best share: 14

     [2015-03-21 20:13:52] New best share: 29

     [2015-03-21 20:13:55] New best share: 65

     [2015-03-21 20:14:07] New best share: 102


    Then the button changes back to Start.

  • edited March 2015
    That's really curious! Have you been watching the API Output window, which shows stats for individual devices? Whatever shows up there should show up in MobileMiner, if not something is wrong…

    I have a BFL Jalapeño that worked fine for a few months, but then started causing bfgminer to stop about every 10mins, some kind of hardware error = hence MacMiner automatically starting mining again when that happens. So I wonder whether one of the devices is problematic - maybe try running one in the GPU window and the rest in devices window swapping out until you identify the problem unit?

    To set clocks for individual miners you need to identify each miner's serial number and set like this:

    -S antminer:all --set antminer@<serial_number>:clock=550 --set antminer@<serial_number>:clock=550 --set antminer@<serial_number>:clock=550 --set antminer@<serial_number>:clock=550 --set antminer@<serial_number>:clock=550 --set antminer@<serial_number>:clock=550
  • Ahh. I was wondering how I would do that. I'll start by just unplugging the U2s to see if the U3 will behave on its own.
  • First try was no good. So I restarted the U3 too. Then it ran a little, but ended up stopping. So, maybe it is bad. *sigh* I even invested in a better power supply for it.
  • ack, what are the manual flags you're using, and are any other options set in the config panel? The U3 driver is still in beta so it could be that… Still got the original power supply?
  • As for MobileMiner, I think it is showing things correctly now for the most part.

  • I removed all the manual flags, basically, I'm just telling it to try to detect antminer in the settings window.

Leave a Comment

Drop image/file