background

How to change Rockminer R BOX Frequency and increase hashrate ?

edited March 2015 in Support
Hey everybody, I am sort of new to mining, although I've already been making some few bitcoins per day, I still can't reach the 100-110 ghs that were advertised, instead I get 70-80 ghs but no more than that.  I want to know if anyone knows exactly how to change the frequency in macminer and if so , what frequency is suggested ? Thanks in advance.

Comments

  • Are you using the cgminer window or the ASIC/bfgminer window? if cg the flags should look like this I think

    --rock-freq 330

    with 330 a commonly mentioned frequency

    didn't find any clock setting for r-box in bfgminer in my quick search though
  • I am using the FPGA/ASIC window. So do I put the --rock-freq 330 on the FPGA/ASIC window ? 
  • in the FPGA/ASIC window it's using bfgminer - the info is sparse and bitcointalk.org seems to be down but at least for the 30gh devices you would use the flag (in MacMiner options panel for the FPGA/ASIC window)

    --set rockminer:clock=330

    Keep in mind that increasing your clock while potentially increasing hash rate also increases heat output power consumption per GH (decreasing efficiency) so if your profitability is affected by power costs you might actually be better off UNDER clocking the device which would also lower the chance of component failures.
  • I also have another question, I already put in the --set rockminer:clock=330 but when I put it in the manual flags, the FPGA/ASIC window goes blank and stops working, so I'm assuming I also have to put the -S rockminer:all   in order for it to detect the rockminer right? but How do I put both at the same time without erasing one or the other ?
  • now that I've done that, macminer seems to restart and my hashrate is super low like at 8 ghs :/ I don't know what I did wrong
  •  -S rockminer:all  --set rockminer:clock=330

    that should do it - with the speed problem the clock must be either too high or too low. Try 320 which should be default and see how it works, just to make sure the clock setting isn't failing to work due to being designed for the last generation rbox
  • edited March 2015
    Actually it looks as though the bfgminer command for the 100GH units is 

    -S rkm:all --set rkm:clock=290

    decrease the clock to 250 to see whether pushing it to 330 is causing it to fail, and lower average hash rate, then step it up in increments

    But if you want to get the full speed out of the box it looks as though you'll need to use the cgminer window

    To test that out enter this command in Terminal
    sudo kextunload -b com.silabs.driver.CP210xVCPDriver64

    Then start the CGMiner window
    If you have other USB miners that depend on this driver they should be switched to that window too as CG requires these drivers not to be installed to work while bfgminer requires them to see the devices.

    If that works well you should uninstall the silabs driver.

Leave a Comment

Drop image/file