background

incompatable library version bfgminer requires version 8.0.0 or later

edited February 2014 in bfgminer for Mac OS X
Hi, i just downloaded and so far so good, only thing when starting mining i got
this message: Reason: Incompatible library version: bfgminer requires version 8.0.0 or later, but libcurl.4.dylib provides version 6.0.0
What can i do to fix this?

thanks !
woef

Comments

  • This should usually only happen if you've rearranged the downloaded stuff, like moving the bfgminer folder out of the bfgminer-3.10-mac folder
  • i have just downloaded it and used it from there, did not rearrange any folder
    i use 10.6 snowleopard and 1.4 macminer
    anything comes to mind?
    thanks
  • the 10.6 version of MacMiner needs to be in your Applications folder to work :)
  • Hi thanks, that worked of course. ;-)
    i am mining for dogecoins, but i am not sure if that works well with macminer.
    I am quite green in mining, so i am not sure if i am actually mining.






    I get the follow text in macminer.

    i get refused for a pool or rejected. It jumps from pool to pool and i do not see any activity in the pool dashboard it self. My worker is inactive. 

    Could you tell if i am on the right way?

    Thanks!

     [2014-02-02 21:20:40] HTTP request failed: Failed connect to mining.harvestcoin.com:9327; Connection refused

     [2014-02-02 21:20:40] Stratum connect failed to pool 2: Failed connect to mining.harvestcoin.com:9327; Connection refused

    5s:  0.0 avg:  0.0 u:  0.0 kh/s | A:0 R:0+0(none) HW:0          

    5s:  0.0 avg:  0.0 u:  0.0 kh/s | A:0 R:0+0(none) HW:0          

  • It should work fine, but you should delete the backup pools. Does it find your GPU? you should also try the CPU miner window
  • these are the settings
    intensity: in the middle
    work size: automatic
    vectors: automatic
    disable GPU mining: not checked
    (so GPU mining is on)
    enable quite output: not checked
    Use scripts (e.g. for litecoin): checked
    Thread concurrency: automatic
    all other: default

    I do not know how to delete the backup pools.
    i do not know whether it finds my GPU.
    How do i try the cPU miner window?
    (like i as i am green as grass, sorry for all these questions)

    This is what i get







    [2014-02-02 21:58:52] HTTP request failed: Failed connect to mining.harvestcoin.com:9327; Connection refused

     [2014-02-02 21:58:52] HTTP request failed: Failed connect to mining.harvestcoin.com:9327; Connection refused

     [2014-02-02 21:58:53] Stratum connect failed to pool 2: Failed connect to mining.harvestcoin.com:9327; Connection refused

    5s:  0.0 avg:  0.0 u:  0.0 kh/s | A:0 R:0+0(none) HW:0          

    5s:  0.0 avg:  0.0 u:  0.0 kh/s | A:0 R:0+0(none) HW:0          

    5s:  0.0 avg:  0.0 u:  0.0 kh/s | A:0 R:0+0(none) HW:0          

     [2014-02-02 21:59:06] Stratum from pool 0 requested work update

     [2014-02-02 21:59:06] Stratum from pool 0 requested work update                    

    5s:  0.0 avg:  0.0 u:  0.0 kh/s | A:0 R:0+0(none) HW:0          

    Is it normal all these zero's? Also the 0.0 kh/s?


    many thanks!

  • The important bit is the beginning, it should say something about an OCL - can you paste the whole of what prints for the first 5 seconds please?

    if you click edit config manually in the miner settings you can edit the pools there
  • Oh look in the 'View' menu at the top of the screen for the CPU miner
  • add
    In my mining pool i see in my dashboard no activity and my worker is said to be inactive. Something wrong with the connection may be?
    username is user.worker and password is the workers password.
    Is that right?
    thanks
  • If you post the first 5 seconds of the log maybe I can tell you - did you try CPU window too?
  • i deleted the pools, but it is still testing the deleted pools out and then gets refused.
    so somewhere still i need to delete the other pools as well, i guess?
    I do not see any OCL 
    this is the beginning of the proces






    0+0(none) HW:0          

     [2014-02-02 22:24:32] Testing pool http://mining.harvestcoin.com:9327

     [2014-02-02 22:24:33] HTTP request failed: Failed connect to mining.harvestcoin.com:9327; Connection refused

     [2014-02-02 22:24:33] HTTP request failed: Failed connect to mining.harvestcoin.com:9327; Connection refused

     [2014-02-02 22:24:33] Stratum connect failed to pool 2: Failed connect to mining.harvestcoin.com:9327; Connection refused

    5s:  0.0 avg:  0.0 u:  0.0 kh/s | A:0 R:0+0(none) HW:0          

    5s:  0.0 avg:  0.0 u:  0.0 kh/s | A:0 R:0+0(none) HW:0          

     [2014-02-02 22:24:43] Stratum from pool 0 requested work update

     [2014-02-02 22:24:43] Stratum from pool 0 requested work update


  • any options to set for cpu miner?
  • http:// before stratum in pool settings config file? (after url?)
  • i get the same library error where i started this support question with
    when i look at cpu miner (it says bfgminer started) ???
  • CPU says bfg when it starts but it shouldn't have the library problem, is it in the applications folder called MacMiner.app? What does your config file look like when you edit it manually - the LTC one?
  • Hi FB,
    below is from the start of mining. Hope this sheds any light?






    [2014-02-03 09:23:31] Failed to init GPU thread 1, disabling device 1                    

     [2014-02-03 09:23:32] Stratum from pool 0 requested work update                    

    5s:  0.0 avg:  0.0 u:  0.0 kh/s | A:0 R:0+0(none) HW:0      


    Below is my new config file:





    {

    "pools" : [

    {

    "url" : "stratum+tcp://doge.united-miners.com:3337",

    "user" : "woefwoef.1",

    "pass" : "x"

    }

    ],


    "kernel-path" : "/Applications/MacMiner.app/Contents/Resources/bfgminer/bin"

    }

    Even though i changed the config file in the above one, it is still looking for harvestcoin.com which i deleted in the config file. See below:

    Connection refused










     [2014-02-03 09:34:34] HTTP request failed: Failed connect to mining.harvestcoin.com:9327; Connection refused

    I tried CPU miner again, but that doesn't work, it gives me the library compatability error again, though the macminer.app is in the applications folder.

    Mystery?


    thanks for your input!

    woef

  • What GPU do you have? Looks like it can't use it. Can you paste the CPU Miner error? What Mac are you using?














  • GPU: NVIDIA GeForce 9400M and NVIDIA GeForce 9600M GT

    Mac: 10.6.8 mac  2.8 GHz Intel Core 2 Duo processor

    CPU Miner error (upon start) 

    dyld: Library not loaded: /Applications/MacMiner.app/Contents/Resources/opt/curl/lib/libcurl.4.dylib






      Referenced from: /Applications/MacMiner.app/Contents/Resources/minerd

      Reason: Incompatible library version: minerd requires version 7.0.0 or later, but libcurl.4.dylib provides version 6.0.0

    I have no clue why it is not working. Hope you do?!

    thanks









  • ooh, that looks like a bad bug I've left in the 10.6 version. Can you please download the latest version (1.5.11b) and right click it - show package contents
    then go Contents-Resources and there's an executable there called minerd - copy the one from the new version to the same place in the 10.6 version replacing the one that's there, and let me know if that works! If so I'll get a fix up soon
  • Hi, i did it, and it doesn't start at all. the gpu mining is the same in this minerd version, no mining as well.

    ??
  • Ah, you could run minerd at the command line - I'm afraid the app will have to wait for an update though :S
  • ok, when do you expect it to be ready for 10.6 mac?
  • a week or two probably, it's been a while so I have to dust the project off!
  • The new 10.6 version is here! Please let me know how you get on with it :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file