background

CPU Settings for Mac XMR Miner (Turtle Coin)

Hey all, first off just want to send thanks to FabulousPanda for putting this together for Mac.

I wanted to ask as I've searched the forums but can't seem to dial into where to adjust my cpu settings. As in affinities and so forth. Might you guys know where I can find that settings file? Or what it's called?

Comments

  • No problem!

    If you're running xmr-stak, the first time you run it it should generate a config for the cpu called cpu.txt in the same folder.

  • Awesomeness, found it, thanks! Weirdly enough it still looks like it's assigning affinities even though I've edited them to "false"?

    [2018-02-15 10:38:51] : Start mining: MONERO
    [2018-02-15 10:38:51] : WARNING on MacOS thread affinity is only advisory.
    [2018-02-15 10:38:51] : Starting 1x thread, affinity: 0.
    [2018-02-15 10:38:51] : hwloc: set_thisthread_membind not supported
    [2018-02-15 10:38:51] : WARNING on MacOS thread affinity is only advisory.
    [2018-02-15 10:38:51] : Starting 1x thread, affinity: 2.
    [2018-02-15 10:38:52] : MEMORY ALLOC FAILED: mmap failed
    [2018-02-15 10:38:52] : hwloc: set_thisthread_membind not supported
    [2018-02-15 10:38:52] : WARNING on MacOS thread affinity is only advisory.
    [2018-02-15 10:38:52] : Starting 1x thread, affinity: 4.
    [2018-02-15 10:38:53] : MEMORY ALLOC FAILED: mmap failed
    [2018-02-15 10:38:53] : hwloc: set_thisthread_membind not supported
    [2018-02-15 10:38:53] : MEMORY ALLOC FAILED: mmap failed
    [2018-02-15 10:38:53] : Fast-connecting to turtlepool.space:3333 pool ...
    [2018-02-15 10:38:53] : Pool turtlepool.space:3333 connected. Logging in...
    [2018-02-15 10:38:54] : Difficulty changed. Now: 5000.
    [2018-02-15 10:38:54] : Pool logged in.

  • What are you trying to achieve? If you want to use less threads than have been auto configured, you delete as many lines as threads you want to remove from the config, i.e. changing this:

        { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 0 },
        { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 2 },
        { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 4 },
        { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 6 },
    

    to this:

        { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 0 },
        { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 2 },
    

    to go from 4 threads to 2.

  • You got it, on wanting fewer threads. Weirdly enough it doesn't seem to be applying settings from the config or the cpu.txt files after I've changed them.

  • Did you restart the miner? The changes won't take effect on an instance of the miner that's currently running. If just that doesn't work try closing the Terminal window and opening a new one.

  • Yup, multiple times, restarts, the whole shindig. Weird/odd :/. I wonder where it's pulling settings from if not from the latest config files

  • edited February 18

    Is the config file in the same folder as the miner binary and what other config files are in the same folder? You can specify a config file manually by adding
    -c /path/to/config.txt
    to the launch arguments.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file