background

new miner. need help with settings

this is what i only get when i start, as far as following the instructions are, i must put the wallet as the username
and a password that i should determine. after that i click on start and it should go right?

currently, it is at 74.75 mh/s... is it doing anything?


[2018-01-28 00:08:01] Testing pool http://ask.gxsnmp.org:9332/
[2018-01-28 00:08:01] Stratum connect failed to pool 1: Couldn't resolve host 'ask.gxsnmp.org'
20s:79.16 avg:85.67 u:32.17 Mh/s | A:0 R:0+0(none) HW:0/none
20s:80.19 avg:85.49 u:30.64 Mh/s | A:0 R:0+0(none) HW:0/none
20s:80.42 avg:85.27 u:29.25 Mh/s | A:0 R:0+0(none) HW:0/none

Comments

  • what does this mean? also, any suggested pools? or other things to mine besides sha256? everything else fails when i try them and this is the one that moves forward and gives values. thanks1

  • Don't put http:// in the pool config - that's the wrong protocol. Just delete that part from the pool and it should work. But yeah, I'd recommend mining something other than SHA256 as the difficulty is too hard unless you have an ASIC.

  • i forgot to put the pool port and i dont know how to set it now
    can u help me pls

  • do you have a pool to suggest and what to mine?

    i dont't see the daggerhashimoto algorithm here and i think amd's are good for that somehow?

    thanks!

  • edited February 18

    I don't tend to make those suggestions, it depends what you're intention is. If you're in it for profit there are sites that keep track of the currently most profitable coins/algos you can find, or if it's more personal interest I'd suggest looking at the technicals of various coins and seeing which has a philosophy you like.

    dagger-hashimoto turned in to ethash which ethereum uses, there is very basic support in it for MacMiner with the included ethminer from here
    https://github.com/ethereum-mining/ethminer

    To use it in MacMiner, open the GPU miner window and use the manual flags in it's settings to enter your pool info and whether you're mining on amd, nvidia or both using the relevant flags from this list:

    Usage ethminer [OPTIONS]
    Options:

    Work farming mode:
    -F,--farm Put into mining farm mode with the work server at URL (default: http://127.0.0.1:8545)
    -FF,-FO, --farm-failover, --stratum-failover Failover getwork/stratum URL (default: disabled)
    --farm-retries Number of retries until switch to failover (default: 3)
    -S, --stratum Put into stratum mode with the stratum server at host:port
    -SF, --stratum-failover Failover stratum server at host:port
    -O, --userpass <username.workername:password> Stratum login credentials
    -FO, --failover-userpass <username.workername:password> Failover stratum login credentials (optional, will use normal credentials when omitted)
    --work-timeout reconnect/failover after n seconds of working on the same (stratum) job. Defaults to 180. Don't set lower than max. avg. block time
    -SC, --stratum-client Stratum client version. Defaults to 1 (async client). Use 2 to use the new synchronous client.
    -SP, --stratum-protocol Choose which stratum protocol to use:
    0: official stratum spec: ethpool, ethermine, coinotron, mph, nanopool (default)
    1: eth-proxy compatible: dwarfpool, f2pool, nanopool (required for hashrate reporting to work with nanopool)
    2: EthereumStratum/1.0.0: nicehash
    -RH, --report-hashrate Report current hashrate to pool (please only enable on pools supporting this)
    -HWMON Displays gpu temp and fan percent.
    -SE, --stratum-email Email address used in eth-proxy (optional)
    --farm-recheck Leave n ms between checks for changed work (default: 500). When using stratum, use a high value (i.e. 2000) to get more stable hashrate output

    Benchmarking mode:
    -M [],--benchmark [] Benchmark for mining and exit; Optionally specify block number to benchmark against specific DAG.
    --benchmark-warmup Set the duration of warmup for the benchmark tests (default: 3).
    --benchmark-trial Set the duration for each trial for the benchmark tests (default: 3).
    --benchmark-trials Set the number of benchmark trials to run (default: 5).
    Simulation mode:
    -Z [],--simulation [] Mining test mode. Used to validate kernel optimizations. Optionally specify block number.
    Mining configuration:
    -G,--opencl When mining use the GPU via OpenCL.
    -U,--cuda When mining use the GPU via CUDA.
    -X,--cuda-opencl Use OpenCL + CUDA in a system with mixed AMD/Nvidia cards. May require setting --opencl-platform 1
    --opencl-platform When mining using -G/--opencl use OpenCL platform n (default: 0).
    --opencl-device When mining using -G/--opencl use OpenCL device n (default: 0).
    --opencl-devices <0 1 ..n> Select which OpenCL devices to mine on. Default is to use all
    -t, --mining-threads Limit number of CPU/GPU miners to n (default: use everything available on selected platform)
    --list-devices List the detected OpenCL/CUDA devices and exit. Should be combined with -G or -U flag
    -L, --dag-load-mode DAG generation mode.
    parallel - load DAG on all GPUs at the same time (default)
    sequential - load DAG on GPUs one after another. Use this when the miner crashes during DAG generation
    single - generate DAG on device n, then copy to other devices
    --cl-local-work Set the OpenCL local work size. Default is 128
    --cl-global-work Set the OpenCL global work size as a multiple of the local work size. Default is 8192 * 128
    --cl-parallel-hash <1 2 ..8> Define how many threads to associate per hash. Default=8
    --api-port Set the api port, the miner should listen to. Use 0 to disable. Default=0, use negative numbers to run in readonly mode. for example -3333.
    General Options:
    -v,--verbosity <0 - 9> Set the log verbosity from 0 to 9 (default: 8).
    -V,--version Show the version and exit.
    -h,--help Show this help message and exit.

  • i am getting this error

    33m cl [35m07:49:59[0m[30m|[34mcl-1 [0m No work. Pause for 3 s.
    [33m cl [35m07:49:59[0m[30m|[34mcl-0 [0m No work. Pause for 3 s.
    JSON-RPC problem. Probably couldn't connect. Retrying in 1...
    [32m m [35m07:50:00[0m[30m|[34m [0m Waiting for work package...
    [101m[1;30m ✘ [35m07:50:00[0m[30m|[34m [0m Failed to submit hashrate.
    [101m[1;30m ✘ [35m07:50:00[0m[30m|[34m [0m Dynamic exception type: jsonrpc::JsonRpcException
    std::exception::what: Exception -32003 : Client connector error: libcurl error: 7 -> Could not connect to http://127.0.0.1:8545

  • 127.0.01 is the machine you're using a.k.a. localhost. If you haven't set up that machine to mine against it you should use a pool.

  • hi, i see the mine option of eth in the options now, but once i start, i get this error

    Starting…[94m ℹ [35m20:53:26[0m[30m|[34m [0m Found suitable OpenCL device [ Iris Pro[0m ] with 1610612736 bytes of GPU memory
    [33m cl [35m20:53:26[0m[30m|[34mcl-0 [0m No work. Pause for 3 s.
    [33m cl [35m20:53:26[0m[30m|[34mcl-1 [0m No work. Pause for 3 s.
    [32m m [35m20:53:26[0m[30m|[34m [0m Waiting for work package...
    [101m[1;30m ✘ [35m20:53:26[0m[30m|[34m [0m Failed to submit hashrate.
    [101m[1;30m ✘ [35m20:53:26[0m[30m|[34m [0m Dynamic exception type: jsonrpc::JsonRpcException
    std::exception::what: Exception -32003 : Client connector error: libcurl error: 7 -> Could not connect to http://127.0.0.1:8545
    [0m

    what seems to be wrong? or what do i need to change? thanks!

  • ok... i just realized i posted the same thing, how could i change the 127.0.0.1:8545, i could not see where.

  • in the pool settings, i could not see ethereum there so i coulf not change it

  • For ethereum you need to set it up manually with the flags I posted further up the thread. Usually the pool you choose will tell you which ones to use with ethminer.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file