background

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Use Anonymous Ads

cgminer outdated library

Hi!
Im completely new to the cryptomining community and can't figure out what this message means when i launch cgminer with macminer.

dyld: Library not loaded: /Applications/MacMiner.app/Contents/Resources/curl/lib/libcurl.4.dylib
Referenced from: /var/folders/vc/zhw0h_ln3515t7mvkymsr0300000gn/T/AppTranslocation/8D656BC2-6296-46D6-89A0-A6BDBEEA3A26/d/MacMiner.app/Contents/Resources/cgminer/bin/cgminer
Reason: Incompatible library version: cgminer requires version 8.0.0 or later, but libcurl.4.dylib provides version 7.0.0

Tried google but Im lost in translation!
Any help would be much appreciated!
Thanks

Comments

  • Which version of MacMiner is that, the latest release? I suppose it's possible I updated cgminer and left an old version of curl in there, but I'd have thought I'd have heard something by now…

    My machines all have custom curls so they don't throw up the warning even if I've left the bug in!

    I'm soon to release a minor update for MacMiner so I'll recompile curl for this version.

    Are you using cgminer for an ASIC though? That's it's only usage case these days, if you're trying to CPU/GPU mine it doesn't do that in the latest versions.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file