background

BFGMiner asking for Device?

I'm at the beginning of setting up and I'm getting this message:

"Enter "auto", "all", or a serial port to probe for mining devices.
Prefix by a driver name and colon to only probe a specific driver.
For example: erupter:/dev/cu.SLAB_USBtoUART
Enter target:"

When I type "auto" I get

(no devices)
[Plus] Add device(s) [Enter] Close device manager
No new devices found

I'm not sure how to write the address for my device or how to identify my device. I'm using a MBP - MacBook Pro (13-inch, Early 2011)

Thank you

Comments

  • You're talking about devices that you would have plugged in to your computer. You could use the MBP to mine with the CPU or GPU but it's impossible now for Bitcoin so you'd have to educate yourself and look for another crypto to mine with a lower difficulty.

  • could you please let me know how to add the intel hd 4000? want to try gpu mining some alt coins.

  • If it'll work it'd be the same as any other GPU, but you'd get really slow results and it's probably not worth GPU mining with integrated graphics.

  • edited December 2017

    thanks. I already solved that part out and even got it to work for a few minutes. However, i tried it later and it doesn't work and there's another problem. As this was my first try at GPU mining, I didn't realize this miner wouldn't support neoscrypt so I added a neoscrypt pool. Now, even if I delete (or disable) it and add another one, it always comes back to the old one when I reopen it. I'm really not doing this for profit, just to get to understand this better.
    I also tried with Mac Miner GPU, a similar MacBook Pro (though with 10.6.8) with Nvidia card and i can't it to work either.

    I just wish I could GPU mine cryptonight alg. with my mac but I can't find any miner to do so.

  • xmr-stak uses cryptonight but I wouldn't recommend it on any Mac that has integrated graphics, it'll probably burn the thing out.

    What does the pool config say in ~/Library/Application Support/MacMiner?

  • edited January 15

    Hello @FabulousPanda i tried to configure the BFG miner on GPU to mine litecoin (i know, its nonprofitable, but i need to teach it for other devices) on litecoinpool.org. I have the newest High Sierra on the MacBook Pro Late 2014 with NVIDIA GeForce GT 750M 2 GB. I tried it hundred times but still unsucessful.

    Its says:Starting… [2018-01-15 16:33:56] /var/folders/fz/46b_sbcd48z3qfc96rg0svlc0000gp/T/AppTranslocation/A824E938-E74B-4447-BD37-BFB398B4FEFE/d/MacMiner.app/Contents/Resources/bfgminer/bin/bfgminer: -c: JSON decode of file '/Users/Wosker/Library/Application Support/MacMiner/ltcurls.conf' failed
    unexpected newline near '"1'

    [2018-01-15 16:33:56] /var/folders/fz/46b_sbcd48z3qfc96rg0svlc0000gp/T/AppTranslocation/A824E938-E74B-4447-BD37-BFB398B4FEFE/d/MacMiner.app/Contents/Resources/bfgminer/bin/bfgminer: -c: JSON decode of file '/Users/Wosker/Library/Application Support/MacMiner/ltcurls.conf' failed
    unexpected newline near '"1'

    Config of pool from library -> application support:

    {
    "pools" : [
    {
    "url" : "stratum+tcp://litecoinpool.org:3333",
    "user" : "Woskerable.1",
    "pass" : "1
    "
    }
    ]

    }

    Please advise.....prevously it says like" -30 debug output" or something but card was detected like virtual :(

  • There's a newline in there:
    "pass" : "1
    "
    You should edit the file and remove it being careful not to let any autocorrect curly quotes slip in there as you do so.

  • There's a newline in there:
    "pass" : "1
    "
    You should edit the file and remove it being careful not to let any autocorrect curly quotes slip in there as you do so.

    Allright, i tried it and and really lame :( How should settings looks like if credentials to worker on my pool is (litecoinpool.org): my username: Woskerable.1 pass:1, adress is: stratum+tcp://litecoinpool.org:3333 - still throwing the same error or quite simmilar.

    Can we contact via email please to send the screenshots or pics? I am really new at mining on Mac, and i very appreciate your help Fabulous Panda :)> @FabulousPanda said:

  • {
    "pools" : [
    {
    "url" : "stratum+tcp://litecoinpool.org:3333",
    "user" : "Woskerable.1",
    "pass" : "1"
    }
    ]

    }

    That should work. It's probably just that you pasted in the password and there was a newline in the clipboard? You could delete the conf file and set the pool up again in the preferences if need be.

  • Thank you man :) i am almost here :) Know as you can see, it looks so much better, but now its a new thing. I can always can hear error voice: Authorization failed.

    Logs:
    Starting… [2018-01-17 17:55:29] Started bfgminer 5.4.2-unknown

    [2018-01-17 17:55:29] Started bfgminer 5.4.2-unknown
    [2018-01-17 17:55:29] Loaded configuration file /Users/Wosker/Library/Application Support/MacMiner/ltcurls.conf

    [2018-01-17 17:55:29] Loaded configuration file /Users/Wosker/Library/Application Support/MacMiner/ltcurls.conf
    [2018-01-17 17:55:29] CL Platform 0 vendor: Apple
    [2018-01-17 17:55:29] CL Platform 0 name: Apple
    [2018-01-17 17:55:29] CL Platform 0 version: OpenCL 1.2 (Oct 31 2017 18:19:43)
    [2018-01-17 17:55:29] Platform 0 devices: 2
    [2018-01-17 17:55:29] 0 Iris Pro
    [2018-01-17 17:55:29] 1 GeForce GT 750M
    [2018-01-17 17:55:29] Unable to load ati adl library
    [2018-01-17 17:55:29] Probing for an alive pool

    [2018-01-17 17:55:29] Probing for an alive pool
    [2018-01-17 17:55:29] Testing pool stratum+tcp://litecoinpool.org:3333
    [2018-01-17 17:55:29] pool 0 JSON stratum auth failed: (null)

    [2018-01-17 17:55:29] pool 0 JSON stratum auth failed: (null)
    [2018-01-17 17:55:30] No servers were found that could be used to get work from.

    [2018-01-17 17:55:30] No servers were found that could be used to get work from.
    [2018-01-17 17:55:30] Please check the details from the list below of the servers you have input

    [2018-01-17 17:55:30] Please check the details from the list below of the servers you have input
    [2018-01-17 17:55:30] Most likely you have input the wrong URL, forgotten to add a port, or have not set up workers

    [2018-01-17 17:55:30] Most likely you have input the wrong URL, forgotten to add a port, or have not set up workers
    [2018-01-17 17:55:30] Pool: 0 URL: stratum+tcp://litecoinpool.org:3333 User: Woskerable.1. Password: 1

    [2018-01-17 17:55:30] Pool: 0 URL: stratum+tcp://litecoinpool.org:3333 User: Woskerable.1. Password: 1
    No servers could be used! Exiting.

    What is wrong now?

  • It seems something is wrong with the pool setup. You could try removing stratum+tcp:// from the pool info but if that doesn't work you'd have to check with the pool to see why it doesn't like your login info. Is there an unintended full stop at the end of the user though, should Woskerable.1. be Woskerable.1 ?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file