JSON config parse error(offset 1782)

I am getting this error
JSON config parse error(offset 1782): Invalid escape character in string.

ANd i have found it occurs mainly when i use pool settings


  • i have got two aorus 1080ti extreme addition on my mack they are giving around 1.8 k hs on default pool but i want to use em for nanopool

  • coz from last 3 hours moneropool aint showing any progress just hashes so i am skeptical about this pool . will see what it shows after 3 hours but if balance is zero i aint using it

  • This means there's an error with the 1782nd character in the conf file, did you edit it manually? If so it's usually a curly quote that got in there by autocorrect.

  • hey a quick thanks first ill check it but i didnt get what do you mean edit it manually , is there some other way of editing it other then textedit

  • Nope checked it out the error my 1782nd character is coming in my wallet address and therefore it is not an escape character , i just change the mining pool to and it just gives the error

  • Sorry you didn't say what program you were using and I just assumed MacMiner! I tested xmr-stak-cpu with that pool and it didn't throw an error. Can you post the pool config here as is in your config.txt?

  • /*
    * Number of GPUs that you have in your system. Each GPU will get its own CPU thread.
    "gpu_thread_num" : 1,

    * GPU configuration. You should play around with intensity and worksize as the fastest settings will vary.
    * index - GPU index number usually starts from 0
    * intensity - Number of parallel GPU threads (nothing to do with CPU threads)
    * worksize - Number of local GPU threads (nothing to do with CPU threads)
    * affine_to_cpu - This will affine the thread to a CPU. This can make a GPU miner play along nicer with a CPU miner.
    "gpu_threads_conf" : [
    { "index" : 0, "intensity" : 64, "worksize" : 8, "affine_to_cpu" : false },

    * Platform index. This will be 0 unless you have different OpenCL platform - eg. AMD and Intel.
    "platform_index" : 0,

    * TLS Settings
    * If you need real security, make sure tls_secure_algo is enabled (otherwise MITM attack can downgrade encryption
    * to trivially breakable stuff like DES and MD5), and verify the server's fingerprint through a trusted channel.
    * use_tls - This option will make us connect using Transport Layer Security.
    * tls_secure_algo - Use only secure algorithms. This will make us quit with an error if we can't negotiate a secure algo.
    * tls_fingerprint - Server's SHA256 fingerprint. If this string is non-empty then we will check the server's cert against it.
    "use_tls" : false,
    "tls_secure_algo" : true,
    "tls_fingerprint" : "",

    * pool_address - Pool address should be in the form "". Only stratum pools are supported.
    * wallet_address - Your wallet, or pool login.
    * pool_password - Can be empty in most cases or "x".
    "pool_address" : “”,

    THE MOMENT I changed pool address its gives
    JSON config parse error(offset 1749): Invalid value.

    i am using xmr stack on my hackintosh with 1080ti extreme

    it works fine with monero pool but as soon as i add pool address of xmr it gives error.Thanks for reply

  • i am using cmr stack amd for gpu. as i said it works fine on moneropool but gives error on nanopool setting i mentioned above

  • You have curly quotes around the pool. Copy paste standard quote marks from elsewhere in the config and be careful about autocorrect or edit in a code editor like Xcode rather than Textedit.

  • Pretty sure the curly quotes come standard or something. Just resolved my issue with the xmr cpu miner, which was the curly quotes even though I never touched them.

  • Is there any other config needed for xmr because just few minutes after my windows machine is reflected on nanopool but not mac one it is just showing new block found

  • @manshmedia said:
    yeah worked with xcode

    somehow textedit was adding something. NOw my problem is that with nanopool i am not seeing it on the interface of nanopool and i think it is taking double the time to submit result

  • What hash rate are you getting on the hackintosh and on the windows machine? I purposefully set the intensity very low by default to lower the risk to people's hardware. Edit the intensity here:

    { "index" : 0, "intensity" : 64, "worksize" : 8, "affine_to_cpu" : false },

    to a multiple of 8, so you could try 128, 256, 512, 1024 and see how it goes for you.

  • Device 0 work size 8 / 1024

    I think on minerpool it was fast , right here on nanopool my device does not show up as a miner , although i am getting results accepted message. I think on windows i am using tsv miner and its configured for nanopool and it shows up fine on nanopool monitor but this one just submits results , will keep it on for a whole night to see the difference

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file