background

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Use Anonymous Ads

xmr-stak-amd couldn't get it to run on macOS 10.10

Kept getting an error:

dyld: Library not loaded: @executable_path/openssl/lib/libssl.1.0.0.dylib
Referenced from: /Users/sunk818/Downloads/xmr-stak-amd-macOS/bin/./xmr-stak-amd
Reason: image not found
Trace/BPT trap: 5

I was able to compile my own using your instructions on the GitHub thread though:
https://github.com/fireice-uk/xmr-stak-amd/issues/121

Thanks again for your help.

Comments

  • Why is it in a /bin/ folder in your output? It's important to leave the folder structure as it is in the download otherwise you'll have linker issues like that one. Please let me know if it works that way!

  • I verified that I kept the folder structure intact from the download and I am getting the same error on macOS 10.11.6, but with a little more detail:
    xmr-stak-amd-macOS admin$ ./xmr-stak-amd
    dyld: lazy symbol binding failed: Symbol not found: _clock_gettime
    Referenced from: /Users/admin/Desktop/xmr-stak-amd-macOS/./libmicrohttpd/lib/libmicrohttpd.12.dylib (which was built for Mac OS X 10.12)
    Expected in: /usr/lib/libSystem.B.dylib

    dyld: Symbol not found: _clock_gettime
    Referenced from: /Users/admin/Desktop/xmr-stak-amd-macOS/./libmicrohttpd/lib/libmicrohttpd.12.dylib (which was built for Mac OS X 10.12)
    Expected in: /usr/lib/libSystem.B.dylib

    Trace/BPT trap: 5

  • Thanks for the feedback, please redownload the binary and try it again, I've recompiled the included libmicrohttpd to hopefully support 10.6+

  • Here's the error from what I downloaded just a minute ago:
    xmr-stak-amd-macOS admin$ ./xmr-stak-amd
    dyld: lazy symbol binding failed: Symbol not found: _clock_gettime
    Referenced from: /Users/admin/Downloads/xmr-stak-amd-macOS/./libmicrohttpd/lib/libmicrohttpd.12.dylib
    Expected in: /usr/lib/libSystem.B.dylib

    dyld: Symbol not found: _clock_gettime
    Referenced from: /Users/admin/Downloads/xmr-stak-amd-macOS/./libmicrohttpd/lib/libmicrohttpd.12.dylib
    Expected in: /usr/lib/libSystem.B.dylib

    Trace/BPT trap: 5

  • Ack, okay here's a version compiled without libmicrohttpd which means it doesn't have the web interface but should work on older systems:
    http://downloads.fabulouspanda.co.uk/xmr-stak-amd-macOS_nohttpd.zip

  • Would it be possible to get NVIDIA and CPU builds of this as well? Thanks!

  • Hi there... I was first getting the _clock_gettime error.. Running your nohttpd version worked to remove that error however, now I have a weird error stating that my config file is wrong. It says that I have a missing value for gpu_thread_num... however, the value is present in the file. I get this error even when running the binary without touching the config.txt file... Any clue what could be going on?:

    Last login: Sun Jan 14 23:03:07 on ttys002
    iMac:~ imart$ /Users/imart/Downloads/xmr-stak-amd-macOS_nohttpd\ 2/xmr-stak-amd ; exit;
    [2018-01-14 23:16:45] : Invalid config file. Missing value "gpu_thread_num".
    logout
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    ...completed.

    [Process completed]

  • I would recommend using xmr-stak rather than xmr-stak-amd as it's newer and it takes care of more of the setup than xmr-stak-amd did. If you prefer xmr-stak-amd you should take a look at the config.txt file which includes an example GPU config that you need to implement.

  • Hi there, running 10.11 and getting the same warning as above. dyld: lazy symbol binding failed: Symbol not found: _clock_gettime
    Referenced from: /Applications/xmr-stak-cpu/./libmicrohttpd/lib/libmicrohttpd.12.dylib
    Expected in: /usr/lib/libSystem.B.dylib

    I downloaded 2.4.1 but it wouldn't run and gave me the above error. I can run the 2.1 xmr-stak but it only gives me options of running the old forks of aeon or monero. Can you provide any guidance on running 2.4.1 without me upgrading to high sierra?

  • edited May 7

    Please try the 2.4.3 download I've just made available which should work on 10.9 up

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file