background

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Use Anonymous Ads

Problems start Gekkoscience USB miner on Mac

Hello,
it seems i'm having problems on successful start of GekkoScience compact USB SHA-256 miner using MacMiner on Mac book Air 2015Mid (OS X El Capitan)- it gives constant lines (a help would appreciated):

[2016-07-12 22:38:45] No devices detected!

[2016-07-12 22:38:45] No devices detected!
[2016-07-12 22:38:45] Waiting for devices

[2016-07-12 22:38:45] Waiting for devices
[2016-07-12 22:38:45] Probing for an alive pool

[2016-07-12 22:38:45] Probing for an alive pool
[2016-07-12 22:38:45] Testing pool stratum+tcp://eu.stratum.bitcoin.cz:3333
[2016-07-12 22:38:46] Stratum authorisation success for pool 0
[2016-07-12 22:38:46] Pool 0 stratum+tcp://eu.stratum.bitcoin.cz:3333 alive

[2016-07-12 22:38:46] Pool 0 stratum+tcp://eu.stratum.bitcoin.cz:3333 alive
[2016-07-12 22:38:46] Pool 0 is hiding block contents from us

[2016-07-12 22:38:46] Pool 0 is hiding block contents from us
[2016-07-12 22:38:46] Network difficulty changed to 213G ( 1.53E)

[2016-07-12 22:38:46] Network difficulty changed to 213G ( 1.53E)
[2016-07-12 22:38:46] New block: ...b4996ed9e263bd88 diff 213G ( 1.53E)
[2016-07-12 22:38:46] Stratum from pool 0 detected new block

[2016-07-12 22:38:46] Stratum from pool 0 detected new block
[2016-07-12 22:38:46] API running in IP access mode on port 4028

[2016-07-12 22:38:46] API running in IP access mode on port 4028
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none

Comments

  • edited July 2016
    In the FPGA/ASIC miner window, click the cog button and add these manual flags:

    -S compac:all --set compac:clock=x0b83

    Make sure the -S is capitalised. The clock is a hex, here are the hex values for clock rates from https://bitcointalk.org/index.php?topic=1173963.0

    Higher the clock, hotter it runs and more power it draws.

    MHz on the left, hex on the right
    " { 100, 0x0783 },
    { 106.25, 0x0803 },
    { 112.5, 0x0883 },
    { 118.75, 0x0903 },
    { 125, 0x0983 },
    { 131.25, 0x0a03 },
    { 137.5, 0x0a83 },
    { 143.75, 0x1687 },
    { 150, 0x0b83 },
    { 156.25, 0x0c03 },
    { 162.5, 0x0c83 },
    { 168.75, 0x1a87 },
    { 175, 0x0d83 },
    { 181.25, 0x0e83 },
    { 193.75, 0x0f03 },
    { 196.88, 0x1f07 },
    { 200, 0x0782 },
    { 206.25, 0x1006 },
    { 212.5, 0x1086 },
    { 218.75, 0x1106 },
    { 225, 0x0882 },
    { 231.25, 0x1206 },
    { 237.5, 0x1286 },
    { 243.75, 0x1306 },
    { 250, 0x0982 },
    { 256.25, 0x1406 },
    { 262.5, 0x0a02 },
    { 268.75, 0x1506 },
    { 275, 0x0a82 },
    { 281.25, 0x1606 },
    { 287.5, 0x0b02 },
    { 293.75, 0x1706 },
    { 300, 0x0b82 },
    { 306.25, 0x1806 },
    { 312.5, 0x0c02 },
    { 318.75, 0x1906 },
    { 325, 0x0c82 },
    { 331.25, 0x1a06 },
    { 337.5, 0x0d02 },
    { 343.75, 0x1b06 },
    { 350, 0x0d82 },
    { 356.25, 0x1c06 },
    { 362.5, 0x0e02 },
    { 368.75, 0x1d06 },
    { 375, 0x0e82 },
    { 381.25, 0x1e06 },
    { 387.5, 0x0f02 },
    { 393.75, 0x1f06 },
    { 400, 0x0f82 },
    { 412.5, 0x1006 },
    { 425, 0x0801 },
    { 437.5, 0x1105 },
    { 450, 0x0881 },
    { 462.5, 0x1205 },
    { 475, 0x0901 },
    { 487.5, 0x1305 },
    { 500, 0x0981 },"
  • Greetings,
    Newb here. I am having the exact same problem. Miner won’t start.
    Green light is on.
    Is there a specific “Gekko” version of mining software for OSX?
    No matter which software I use, “No device detected”

    However it reports:

    computer$ cgminer --ndevs
    [2016-07-19 10:10:40] USB all: found 4 devices - listing known devices
    .USB dev 0: Bus 61 Device 1 ID: 10c4:ea60
    Manufacturer: 'GekkoScience'
    Product: 'Compac BM1384 Bitcoin Miner'
    [2016-07-19 10:10:40] 1 known USB devices

    Please help! Not sure where to go from here. Any help is much appreciated.
    -r

    LOGS and INFO below:

    Mac Pro 10.11.6 (EL CAP)
    GekkoScience Compac
    MacMiner 1.5.4
    Device Flags: -S compact:all --set compact:clock=x0b83

    Tried:
    MacMiner 1.5.41
    MacMiner 1.5.40
    MacMiner 1.5.31
    cgminer 4.9.2
    cgminer 4.9.1
    bfgminer 5.4.1
    Asteroid
    Several Pools

    MACMINER LOG:

    [2016-07-19 16:35:24] Started bfgminer 5.4.2-unknown

    [2016-07-19 16:35:24] Started bfgminer 5.4.2-unknown
    [2016-07-19 16:35:24] Loaded configuration file /Users/…/bfgurls.conf (Path removed)

    [2016-07-19 16:35:24] Loaded configuration file /Users/…/bfgurls.conf (Path removed)
    [2016-07-19 16:35:24] No devices detected!

    [2016-07-19 16:35:24] No devices detected!
    [2016-07-19 16:35:24] Waiting for devices

    [2016-07-19 16:35:24] Waiting for devices
    [2016-07-19 16:35:24] Probing for an alive pool

    [2016-07-19 16:35:24] Probing for an alive pool
    [2016-07-19 16:35:24] Testing pool stratum+tcp://sha256.usa.nicehash.com:3334
    [2016-07-19 16:35:25] Stratum authorisation success for pool 0
    [2016-07-19 16:35:25] Pool 0 stratum+tcp://sha256.usa.nicehash.com:3334 alive

    [2016-07-19 16:35:25] Pool 0 stratum+tcp://sha256.usa.nicehash.com:3334 alive
    [2016-07-19 16:35:25] Network difficulty changed to 213G ( 1.53E)

    [2016-07-19 16:35:25] Network difficulty changed to 213G ( 1.53E)
    [2016-07-19 16:35:25] API running in IP access mode on port 4028

    [2016-07-19 16:35:25] API running in IP access mode on port 4028
    [2016-07-19 16:35:25] New block: ...75783c98e7a7abd5 diff 213G ( 1.53E)

    20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
    20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
    [2016-07-19 16:36:10] Pool 0 is hiding block contents from us

    [2016-07-19 16:36:10] Pool 0 is hiding block contents from us
    20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none

    CGMINER LOG:

    computer$ ./cgminer

    cgminer version 4.9.1 - Started: [2016-07-19 12:34:06]
    --------------------------------------------------------------------------------
    (5s):0.000 (1m):0.000 (5m):0.000 (15m):0.000 (avg):0.000h/s
    A:0 R:0 HW:0 WU:0.0/m
    Connected to btc.pool.minergate.com diff 32 with stratum as user

    Block: 231f57cb... Diff:213G Started: [12:34:06] Best share: 0
    --------------------------------------------------------------------------------
    [U]SB management [P]ool management [S]ettings [D]isplay options [Q]uit
    --------------------------------------------------------------------------------
    [2016-07-19 12:33:32] Started cgminer 4.9.1
    [2016-07-19 12:33:43] No devices detected!
    [2016-07-19 12:33:43] Waiting for USB hotplug devices or press q to quit

    [2016-07-19 12:34:05] Probing for an alive pool
    [2016-07-19 12:34:06] Pool 0 difficulty changed to 32
    [2016-07-19 12:34:06] Network diff set to 213G



  • Sorry, that should have been compac not compact as in previous post - autocorrect!

    Device Flags: -S compac:all --set compac:clock=x0b83
  • Hello,

    I have the same problem and the device flag you provided does not seem to work. I would be utmost grateful for your support. The device is plugged in and the green LED is on. I am using MacMiner version 1.5.42.

    Here is the log:

    [2017-05-01 15:26:40] Started bfgminer 5.4.2-unknown
    [2017-05-01 15:26:40] Loaded configuration file /Users/******/Library/Application Support/MacMiner/bfgurls.conf
    [2017-05-01 15:27:30] No devices detected!
    [2017-05-01 15:27:30] Waiting for devices
    [2017-05-01 15:27:30] Probing for an alive pool
    [2017-05-01 15:27:31] Pool 0 stratum+tcp://sg.stratum.slushpool.com:3333 alive
    [2017-05-01 15:27:31] Pool 0 is hiding block contents from us
    [2017-05-01 15:27:31] Network difficulty changed to 522G ( 3.74E)
    [2017-05-01 15:27:31] Stratum from pool 0 detected new block
    [2017-05-01 15:27:31] API bind to port 4028 failed - trying again in 30sec


    The debug output gives me this:

    [2017-05-01 14:18:05] Timers: Using gettimeofday
    [2017-05-01 14:18:05] Global quota greatest common denominator set to 1
    [2017-05-01 14:18:05] setrlimit: Changed soft fd limit from 2560 to 1024 (FD_SETSIZE=1024; hard limit=unlimited)
    [2017-05-01 14:18:06] Started bfgminer 5.4.2-unknown
    [2017-05-01 14:18:06] Loaded configuration file /Users/*******/Library/Application Support/MacMiner/bfgurls.conf
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 2 (iManufacturer) from usb:093:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 1 (iProduct) from usb:093:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 2 (iManufacturer) from usb:029:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 1 (iProduct) from usb:029:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 2 (iManufacturer) from usb:061:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 1 (iProduct) from usb:061:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 2 (iManufacturer) from usb:026:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 1 (iProduct) from usb:026:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 2 (iManufacturer) from usb:058:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 1 (iProduct) from usb:058:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 2 (iManufacturer) from usb:090:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 1 (iProduct) from usb:090:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 2 (iManufacturer) from usb:253:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 1 (iProduct) from usb:253:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 2 (iManufacturer) from usb:250:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] usb_devinfo_scan: Error getting USB string 1 (iProduct) from usb:250:001: LIBUSB_ERROR_OTHER
    [2017-05-01 14:18:06] hidapi_try_lib: Couldn't load libhidapi.dylib: dlopen(libhidapi.dylib, 2): image not found
    [2017-05-01 14:18:06] hidapi_try_lib: Couldn't load libhidapi-0.dylib: dlopen(libhidapi-0.dylib, 2): image not found
    [2017-05-01 14:18:06] hidapi_try_lib: Couldn't load libhidapi-hidraw.dylib: dlopen(libhidapi-hidraw.dylib, 2): image not found
    [2017-05-01 14:18:06] hidapi_try_lib: Couldn't load libhidapi-libusb.dylib: dlopen(libhidapi-libusb.dylib, 2): image not found
    [2017-05-01 14:18:06] hid_devinfo_scan: Failed to load any hidapi library
  • In older versions apparently it was 'cbm' in place of 'compac' although that shouldn't be the case here... maybe worth a shot. Don't have one to test unfortunately!
  • edited September 2017

    I have a problem with GekkoScience 2Pac (2Pac BM1384).
    The manual flags
    -S compac:all --set compac:clock=x0b83
    are not working.
    Who can help?

  • Try cgminer 4.9.2 on fabulous panda. might show up as AMU 0. You really need to compile the vthoang with gekko support to get 10 GH/s. cgminer 4.9.2 might give 800MH/s.

  • Hi! Could you please tell me what should i use in manual flags cause the -S compac:all --set compac:clock=x0b83 doesnt look to be ok accordong to log:

    [2018-02-12 15:49:29] Stratum authorisation success for pool 0
    [2018-02-12 15:49:29] Pool 0 http://depool.ckpool.org:3333 alive
    [2018-02-12 15:49:30] Received no-transaction-list response for pool 0 job 5a76c53600005dc5
    [2018-02-12 15:49:30] Pool 0 is hiding block contents from us
    [2018-02-12 15:49:30] Generated stratum header 2000000063f2161371d164f5709c915fd71c26dc9704ae65006100a300000000000000002bf6c2e18503e2cb011c825bbb1e3bb8e160eac3c021f340efce11fcf99c9d235a81a9731761e9f800000000
    [2018-02-12 15:49:30] Work job_id 5a76c53600005dc5 nonce2 0000000000000000
    [2018-02-12 15:49:30] Network difficulty changed to 2.87T (20.58E)
    [2018-02-12 15:49:30] New block: ...71d164f563f21613 diff 2.87T (20.58E)
    [2018-02-12 15:49:30] Stratum from pool 0 detected new block
    [2018-02-12 15:49:30] Creating extra submit work thread
    [2018-02-12 15:49:30] Selecting pool 0 for work
    [2018-02-12 15:49:30] Generated stratum header 2000000063f2161371d164f5709c915fd71c26dc9704ae65006100a300000000000000002be2127b671ce2ee1c3060ed0e57a90c1681a30f61fff2aebc5368eb4ab022895a81a9731761e9f800000000
    [2018-02-12 15:49:30] Work job_id 5a76c53600005dc5 nonce2 0100000000000000
    [2018-02-12 15:49:30] Generated stratum work
    [2018-02-12 15:49:30] Pushing work 4 from pool 0 to hash queue
    [2018-02-12 15:49:30] Selecting pool 0 for work
    [2018-02-12 15:49:30] Generated stratum header 2000000063f2161371d164f5709c915fd71c26dc9704ae65006100a300000000000000002d23545690ded0dc68784fd68fc56f1cabdc2659c0a61d3f18ccaf4ff4c853465a81a9731761e9f800000000
    [2018-02-12 15:49:30] Work job_id 5a76c53600005dc5 nonce2 0200000000000000
    [2018-02-12 15:49:30] Generated stratum work
    [2018-02-12 15:49:30] Pushing work 6 from pool 0 to hash queue
    [2018-02-12 15:49:30] API running in IP access mode on port 4028
    [2018-02-12 15:49:30] API: connection from 127.0.0.1 - Accepted
    [2018-02-12 15:49:30] API: recv command: (4) 'devs'
    [2018-02-12 15:49:30] API: send reply: (73) 'STATUS=E,W...'
    [2018-02-12 15:49:30] API: sent all of 73 first go

    thank you!

  • Nothing jumps out at me from that log, is the device showing up in the API Output window?

  • @FabulousPanda said:
    Nothing jumps out at me from that log, is the device showing up in the API Output window?

    Hi! Thank you for answer! Here is only i have in that window:

    [Data for 127.0.0.1]
    [STATUS] =>
    (
    ( [STATUS] => E
    [When] => 1518649533
    [Code] => 10
    [Msg] => No PGAs
    [Description] => bfgminer 5.4.2
    )

  • Here is new log from window ASIC Miner, the speed is 0.0 Gh

    [2018-02-15 00:04:41] Coinbase: (size, pos, addr_count, target, total) = (5222, 5222, 0, 0, 1265416242)
    [2018-02-15 00:04:41] Received stratum notify from pool 0 with job_id=5a76c5360000786e
    [2018-02-15 00:04:41] Generated stratum header 20000000ac90ac20442432d51944352844e370d014eac6e3000ac6560000000000000000673fda2bf542f47d9d98f9746eee9b4f58c03eb582b0934ff3e7170679c1d1115a84c0891761e9f800000000
    [2018-02-15 00:04:41] Work job_id 5a76c5360000786e nonce2 0000000000000000
    [2018-02-15 00:04:41] Work stale due to work update (01 != 02)
    [2018-02-15 00:04:41] Discarded work
    [2018-02-15 00:04:41] Work stale due to work update (01 != 02)
    [2018-02-15 00:04:41] Discarded work
    [2018-02-15 00:04:41] Discarded 2 stales that didn't match current hash
    [2018-02-15 00:04:41] Stratum from pool 0 requested work update
    [2018-02-15 00:04:41] Selecting pool 0 for work
    [2018-02-15 00:04:41] Generated stratum header 20000000ac90ac20442432d51944352844e370d014eac6e3000ac6560000000000000000c139f41bc64e24c3d6c5404c8713b06002eb45dc2abd011ddc5b41d9347e87c85a84c0891761e9f800000000
    [2018-02-15 00:04:41] Work job_id 5a76c5360000786e nonce2 0100000000000000
    [2018-02-15 00:04:41] Generated stratum work
    [2018-02-15 00:04:41] Pushing work 14 from pool 0 to hash queue
    [2018-02-15 00:04:41] Selecting pool 0 for work
    [2018-02-15 00:04:41] Generated stratum header 20000000ac90ac20442432d51944352844e370d014eac6e3000ac656000000000000000035cf1d0ec0883f6791bddccdbd6082b642cc332c46d323b6ea55e5da609635605a84c0891761e9f800000000
    [2018-02-15 00:04:41] Work job_id 5a76c5360000786e nonce2 0200000000000000
    [2018-02-15 00:04:41] Generated stratum work
    [2018-02-15 00:04:41] Pushing work 16 from pool 0 to hash queue
    [2018-02-15 00:04:41] Received no-transaction-list response for pool 0 job 5a76c5360000786e
    [2018-02-15 00:04:46] API bind to port 4028 failed - trying again in 30sec
    20s: 0.0 avg: 0.0 u: 0.0 h/s | A:0 R:0+0(none) HW:0/none
    [2018-02-15 00:05:16] Coinbase output: 948747523 -- 1EcH7pHYTHLo3cbdXfkf6e6Zh5JzCPGumc
    [2018-02-15 00:05:16] Coinbase output: 50599367 -- 176sh81PQupUsFyX6hNL2PTYydSuL7Wu73
    [2018-02-15 00:05:16] Coinbase output: 46432174 --

    CUT

    [2018-02-15 00:07:23] Coinbase output: 0 -- [6a24aa21a9ed2935ebe90f9d60d6415b12bfcdfdb1f7e060f8ded0ae81e7668c48a8d80e05d3]
    [2018-02-15 00:07:23] Coinbase: (size, pos, addr_count, target, total) = (5222, 5222, 0, 0, 1272330512)
    [2018-02-15 00:07:23] Received stratum notify from pool 0 with job_id=5a76c53600007873
    [2018-02-15 00:07:23] Generated stratum header 20000000ac90ac20442432d51944352844e370d014eac6e3000ac656000000000000000031443f6d205f2983dd7238829087ec5b9da24ee959e87f620aa4cce2338fa7425a84c12a1761e9f800000000
    [2018-02-15 00:07:23] Work job_id 5a76c53600007873 nonce2 0000000000000000
    [2018-02-15 00:07:23] Work stale due to work update (06 != 07)
    [2018-02-15 00:07:23] Discarded work
    [2018-02-15 00:07:23] Work stale due to work update (06 != 07)
    [2018-02-15 00:07:23] Discarded work
    [2018-02-15 00:07:23] Selecting pool 0 for work
    [2018-02-15 00:07:23] Discarded 2 stales that didn't match current hash
    [2018-02-15 00:07:23] Stratum from pool 0 requested work update
    [2018-02-15 00:07:23] Generated stratum header 20000000ac90ac20442432d51944352844e370d014eac6e3000ac656000000000000000056aa90bd5ffa704298a13632701651acb6afd20ae9392b74134e154a764d7b3d5a84c12a1761e9f800000000
    [2018-02-15 00:07:23] Work job_id 5a76c53600007873 nonce2 0100000000000000
    [2018-02-15 00:07:23] Generated stratum work
    [2018-02-15 00:07:23] Pushing work 44 from pool 0 to hash queue
    [2018-02-15 00:07:23] Selecting pool 0 for work
    [2018-02-15 00:07:23] Generated stratum header 20000000ac90ac20442432d51944352844e370d014eac6e3000ac656000000000000000079efe79ebd6924d5c92e48d0e0acb378e9ad3e4eaecb856503230eb00cc6776a5a84c12a1761e9f800000000
    [2018-02-15 00:07:23] Work job_id 5a76c53600007873 nonce2 0200000000000000
    [2018-02-15 00:07:23] Generated stratum work
    [2018-02-15 00:07:23] Pushing work 46 from pool 0 to hash queue
    [2018-02-15 00:07:23] Received no-transaction-list response for pool 0 job 5a76c53600007873

  • Which device are you using specifically? Apparently they have a newer one called 2pac which wouldn't be supported yet, but will be soon.

  • @FabulousPanda said:
    Which device are you using specifically? Apparently they have a newer one called 2pac which wouldn't be supported yet, but will be soon.

    Bitcoin USB-Stick Miner bitshopper GekkoScience 2Pac 5,5 bis 25 GH/s

    So the problem is in device?

  • Ah yes, that device is still being worked on by luke-jr (developer of bfgminer) and I believe is currently only supported by this miner:
    https://github.com/vthoang/cgminer

    I haven't compiled that as of right now as I wasn't aware of it until a moment ago and there's been no previous demand.

  • Will you add it please in next version? =)

  • @FabulousPanda said:
    Will do

    Thank you!!! Hope try it soon ))

  • This has been added in MacMiner 1.5.62, please let me know how you get on!

  • @FabulousPanda said:
    This has been added in MacMiner 1.5.62, please let me know how you get on!

    Thanks! Now got this on starting app

    dyld: Library not loaded: /usr/local/opt/libmicrohttpd/lib/libmicrohttpd.12.dylib
    Referenced from: /Applications/MacMiner.app/Contents/Resources/bfgminer/bin/bfgminer
    Reason: image not found

  • Ack, please download .62 again (fixed that and updated libmicrohttpd but didn't change the version number) and let me know if bfgminer runs without issue for you.

    However, the gekko support was added to the cgminer window and not the bfgminer/ASIC miner windows so you'll need to use that one for your gekko!

  • that error still alive. used cgminer window and it work!!! thank you!!!!!! perfect!

  • Hello, dear Panda!

    Seems that something going wrong, maybe its because im noob.

    Could you please take a look at log and tell me why its look like everything is ok but pools doesnt see my activity and the counter (Accepted / Rejected) show nothing in Cgminer window

    Thank you!!!

    [2018-03-08 15:36:42.655] Started cgminer 4.10.0
    [2018-03-08 15:36:42.656] Loaded configuration file /Users/SELEZEN/Library/Application Support/MacMiner/bfgurls.conf
    [2018-03-08 15:36:43.587] BSD 0: 2Pac BM1384 Bitcoin Miner (10014369)
    [2018-03-08 15:36:44.923] Probing for an alive pool
    [2018-03-08 15:36:42.655] Started cgminer 4.10.0
    [2018-03-08 15:36:42.656] Loaded configuration file /Users/SELEZEN/Library/Application Support/MacMiner/bfgurls.conf
    [2018-03-08 15:36:43.587] BSD 0: 2Pac BM1384 Bitcoin Miner (10014369)
    [2018-03-08 15:36:44.923] Probing for an alive pool
    (5s):0.000 (1m):0.000 (5m):0.000 (15m):0.000 (avg):0.000h/s
    [2018-03-08 15:36:45.191] BSD 0: setting frequency to 100.00MHz
    [2018-03-08 15:36:45.564] BSD 0: open cores @ 100.00MHz
    [2018-03-08 15:36:46.120] Pool 0 difficulty changed to 32
    [2018-03-08 15:36:46.935] Network diff set to 45.5M
    [2018-03-08 15:36:45.191] BSD 0: setting frequency to 100.00MHz
    [2018-03-08 15:36:45.564] BSD 0: open cores @ 100.00MHz
    [2018-03-08 15:36:46.120] Pool 0 difficulty changed to 32
    [2018-03-08 15:36:46.935] Network diff set to 45.5M
    (5s):1.864G (1m):200.5M (5m):40.93M (15m):13.69M (avg):5.147Gh/s
    [2018-03-08 15:36:51.938] API running in IP access mode on port 4048 (34)
    [2018-03-08 15:36:51.938] API running in IP access mode on port 4048 (34)
    (5s):5.646G (1m):801.0M (5m):167.8M (15m):56.37M (avg):7.202Gh/s
    (5s):8.329G (1m):1.552G (5m):335.1M (15m):113.1M (avg):8.360Gh/s
    (5s):9.733G (1m):2.292G (5m):509.7M (15m):173.0M (avg):9.022Gh/s
    (5s):10.31G (1m):2.924G (5m):668.6M (15m):228.1M (avg):9.386Gh/s
    [2018-03-08 15:37:11.873] BSD 0: start work @ 100.00MHz
    [2018-03-08 15:37:11.873] BSD 0: start work @ 100.00MHz
    (5s):9.396G (1m):3.531G (5m):840.8M (15m):288.9M (avg):9.414Gh/s
    (5s):10.03G (1m):4.172G (5m):1.023G (15m):353.7M (avg):9.732Gh/s
    [2018-03-08 15:37:24.271] Accepted 0380da69 Diff 73/32 BSD 0
    [2018-03-08 15:37:24.271] Accepted 0380da69 Diff 73/32 BSD 0
    (5s):9.709G (1m):4.700G (5m):1.200G (15m):417.7M (avg):9.716Gh/s
    [2018-03-08 15:37:29.142] Accepted 061076c2 Diff 42/32 BSD 0
    [2018-03-08 15:37:31.765] Network diff set to 45.4M
    [2018-03-08 15:37:31.765] Stratum from pool 0 detected new block at height 0
    [2018-03-08 15:37:29.142] Accepted 061076c2 Diff 42/32 BSD 0
    [2018-03-08 15:37:31.765] Network diff set to 45.4M
    [2018-03-08 15:37:31.765] Stratum from pool 0 detected new block at height 0
    (5s):9.808G (1m):5.111G (5m):1.348G (15m):472.2M (avg):9.717Gh/s
    [2018-03-08 15:37:32.803] Accepted 03b2532b Diff 69/32 BSD 0

  • edited March 8

    I don't understand your last post? What pool are you using? My primary suspect would be that hash rate which is not significant for Bitcoin, so you'd need a low difficulty pool. Is anything showing up in the API Output window in terms of accepted shares?

  • Everything is correct now! Thank you so much for your creation!!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file